Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63015 - [lib32-glibc] ld warning: /usr/lib32/ld-linux.so.2: corrupt GNU_PROPERTY_TYPE (5) size: 0

Attached to Project: Arch Linux
Opened by Charles Curley (Slimerang) - Wednesday, 26 June 2019, 19:00 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Wednesday, 10 July 2019, 06:27 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
After complete system update I receive the following warning while making 32-bit project on my 64-bit system:

/usr/sbin/ld: warning: /usr/lib32/ld-linux.so.2: corrupt GNU_PROPERTY_TYPE (5) size: 0


Additional info:
Packages: gcc-9.1.0-2, gcc-libs-9.1.0-2, lib32-gcc-libs-9.1.0-2, glibc-2.29.-3, lib32-glibc-2.29-3

Steps to reproduce:
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Wednesday, 10 July 2019, 06:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  glibc 2.29-4
Comment by Andreas Baumann (andreas_baumann) - Friday, 28 June 2019, 14:07 GMT
Experienced on Archlinux32 too.
Comment by Andrey Vihrov (andreyv) - Friday, 28 June 2019, 16:27 GMT
Confirmed.

Can be reproduced with a simple "gcc -m32 test.c".
Comment by Michel Koss (MichelKoss1) - Sunday, 30 June 2019, 13:05 GMT
This may be caused by missing "--enable-cet" configure option for 32bit glibc (it's passed only for 64bit):

https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/glibc#n85

https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/glibc#n117

Please rebuild 32bit glibc with "--enable-cet" and test again if this fixes issue.
Comment by Wilson E. Alvarez (Rubonnek) - Tuesday, 02 July 2019, 18:27 GMT
Rebuilding 32bit glibc with "--enable-cet" fixes this for me.

Loading...