Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62999 - [qt5-base] [virtualbox] VM window constantly steals focus

Attached to Project: Arch Linux
Opened by nl6720 (nl6720) - Tuesday, 25 June 2019, 10:17 GMT
Last edited by Antonio Rojas (arojas) - Monday, 01 July 2019, 14:05 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Antonio Rojas (arojas)
Christian Hesse (eworm)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After updating qt5-* packages to 5.13.0-1, VirtualBox VMs started to constantly steal focus. With a running VM I can't really do anything useful with the host, for example after opening Kickoff it immediately closes since the focus is set to the VM window, nor can I use a text editor, by the time I start typing the focus is gone. The VM window itself in not brought to front, it's just set as the active window.

Other programs don't exhibit such issues and neither does the VirtualBox VM Manager, only the VM windows.

After downgrading qt5-* packages to 5.12.4 and also the packages that depend on them, the issue is gone.


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any
virtualbox 6.0.8-2
qt5-base 5.13.0-4
qt5-x11extras 5.13.0-1
kwin 5.16.1-5


Steps to reproduce:
Start a VM and on the host try to open some menu or write something in a text editor.
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 01 July 2019, 14:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  qt5-base 5.13.0-7
Comment by Antonio Rojas (arojas) - Friday, 28 June 2019, 17:39 GMT
Workaround: let the VM capture the mouse once and then release it
Comment by nl6720 (nl6720) - Friday, 28 June 2019, 17:45 GMT
The mouse needs to be released after each interaction with the VM, so it's still annoying.
Comment by Antonio Rojas (arojas) - Sunday, 30 June 2019, 12:33 GMT
Minimizing the VM window also works as a workaround

Upstream report - https://bugreports.qt.io/browse/QTBUG-76742

Unfortunately they can't reproduce it
Comment by nl6720 (nl6720) - Monday, 01 July 2019, 12:31 GMT
  • Field changed: Percent Complete (100% → 0%)
qt5-base 5.13.0-6 does not fully fix the issue.

With the VM window focused, try to open a menu (e.g. Kickoff or plasma-nm) in host. The VM window icon in Plasma's task manager gets a yellow background (previously it got red) and the focus is returned to the VM.
This does not happen every time. When it does happen, the issue stops after 5-10 attempts to open the menu.
Comment by Antonio Rojas (arojas) - Monday, 01 July 2019, 12:38 GMT Comment by nl6720 (nl6720) - Monday, 01 July 2019, 13:48 GMT
qt5-base 5.13.0-7 improved things, but still didn't fix it entirely.
The issue now happens very rarely and is hard to trigger.

The icon in Plasma's icon-only task manager now blinks red when focus shifts. Does the color mean something?
Comment by Antonio Rojas (arojas) - Monday, 01 July 2019, 14:04 GMT
OK so I think this is good enough for a workaround. Let's follow up in te upstream report so this can get properly fixed.

Loading...