Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62983 - [powerline] powerline.zsh is missing unde /usr/share/powerline/bindings/zsh

Attached to Project: Community Packages
Opened by Oskar Roesler (bionade24) - Sunday, 23 June 2019, 11:27 GMT
Last edited by Balló György (City-busz) - Sunday, 01 September 2019, 10:01 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Jiachen Yang (farseerfc)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
powerline.zsh is missing unde /usr/share/powerline/bindings/zsh

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any
Missing file:

https://github.com/powerline/powerline/blob/6257332372bf9f64d928b6a3b53d2842d9c7e01f/powerline/bindings/zsh/powerline.zsh

Steps to reproduce:
./usr/share/powerline/bindings/zsh/powerline.zsh
This task depends upon

Comment by Jiachen Yang (farseerfc) - Sunday, 01 September 2019, 10:39 GMT
Strange that powerline.zsh is provided by python-powerline:
/usr/lib/python3.7/site-packages/powerline/bindings/zsh/powerline.zsh is owned by python-powerline 2.7-3
And python-powerline is a dependency of powerline.

By the way the normal zsh do not have the "." (dot) command, instead it provides "source" command which is the same as dot command for bash. You can "alias .=source" in your .zshrc to use "." as source.
Can you please check whether you have python-powerline installed and whether
source /usr/share/powerline/bindings/zsh/powerline.zsh
works for you?

Loading...