Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#62973 - xorg-server 1.20.5-1 is tearing

Attached to Project: Arch Linux
Opened by Daniel Biro (archbox) - Saturday, 22 June 2019, 09:43 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 11 December 2019, 12:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No


The xorg-server update that was pushed on the 1st of June is tearing for several people, including me. Everything worked fine on xorg-server 1.20.4-1 (setting pacman's mirrorlist to 05/31 solves this issue). The issue is probably that the xf86-video-intel driver is not working properly with the new version, since applying the following trick: makes it a lot better (although sometimes I still experience minor tearings and someone who has the same issue said that it greatly reduces the performance on his computer).
I did a fresh install of arch linux twice after experiencing this issue and it was present on the newly installed system too. Tried using KDE and i3, both had this issue. This is why I believe that the xorg-server package is responsible for the problem.

Additional info:
* package version(s): 1.20.5-1
* My laptop is a Lenovo ideapad 100 with intel VGA, Nvida GeFroce 920MX graphics card, using the xf86-video-intel driver. The nvidia driver seems unrelated, tried using both xf86-video-nouveau and the nvidia driver with bumblebee, but the issue was still there in both cases.

If you need more information about the problem, please contact me.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 11 December 2019, 12:54 GMT
Reason for closing:  Fixed
Comment by sickboy (sickboy) - Tuesday, 25 June 2019, 10:15 GMT
I had the same problem with a lenovo x1 carbon (intel hd) solved with the wiki tips
Comment by glavin lewis (Glavin) - Saturday, 06 July 2019, 11:49 GMT Comment by Daniel Biro (archbox) - Saturday, 06 July 2019, 12:29 GMT
@Glavin Thanks for sharing!
Comment by Daniel Biro (archbox) - Sunday, 07 July 2019, 11:38 GMT
The problem is still present in xorg-server 1.20.5-2
Comment by glavin lewis (Glavin) - Monday, 08 July 2019, 07:27 GMT
Because that is not an upstream update just a rebuild, the patch hasn't been merged yet it should be fixed in 1.20.6-1 hopefully.
Comment by Daniel Biro (archbox) - Saturday, 20 July 2019, 10:40 GMT
@Glavin Oh okay, thanks for the clarification!
Comment by Dietrich Hallentforden (aufkrawall) - Friday, 25 October 2019, 07:36 GMT
Would it be possible to roll out the xorg package with this commit reverted?

It shouldn't cause any additional issues, but fix the broken vsync when using xf86-video-intel DDX.
It is marked for 1.20.6 release, but its release is taking ages.
Comment by Laurent Carlier (lordheavy) - Friday, 25 October 2019, 07:54 GMT
Sure, it should be fine to revert it
Comment by Laurent Carlier (lordheavy) - Friday, 25 October 2019, 08:46 GMT
Please check with xorg-server-1.20.5-4 in testing
Comment by Dietrich Hallentforden (aufkrawall) - Friday, 25 October 2019, 10:41 GMT
Works and no more tearing with xf86-video-intel. :)
If I had known that upstream maintainers are that disinterested to roll out a bugfix in a timely manner, I'd asked much earlier. Anyhow, hopefully it won't be necessary again.