Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62970 - [mesa] VLC segmentation fault since mesa-19.1.0 when using VDPAU

Attached to Project: Arch Linux
Opened by Hellracer (hellracer) - Saturday, 22 June 2019, 08:02 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 04 August 2019, 12:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Video playback of VLC using VDPAU is crashing since the update to mesa-19.1.0

Additional info:
* mesa 19.1.0-3
* xf86-video-ati 1:19.0.1-1
* mesa-vdpau 19.1.0-3
* libvdpau 1.2-1

Steps to reproduce:
Let vlc play any vdpau supported video file. Segmentation fault following with:

[00007f5a10c301e0] avcodec decoder: Using G3DVL VDPAU Driver Shared Library version 1.0 for hardware decoding
EE ../mesa-19.1.0/src/gallium/drivers/r600/r600_shader.c:4289 tgsi_unsupported - DIV tgsi opcode unsupported
EE ../mesa-19.1.0/src/gallium/drivers/r600/r600_shader.c:185 r600_pipe_shader_create - translation from TGSI failed !
EE ../mesa-19.1.0/src/gallium/drivers/r600/r600_state_common.c:878 r600_shader_select - Failed to build shader variant (type=5) -22
EE ../mesa-19.1.0/src/gallium/drivers/r600/r600_shader.c:4289 tgsi_unsupported - DIV tgsi opcode unsupported
EE ../mesa-19.1.0/src/gallium/drivers/r600/r600_shader.c:185 r600_pipe_shader_create - translation from TGSI failed !
EE ../mesa-19.1.0/src/gallium/drivers/r600/r600_state_common.c:878 r600_shader_select - Failed to build shader variant (type=5) -22
Speicherzugriffsfehler (Speicherabzug geschrieben)

Disabling hardware decoding in VLC fixes the problem temporarily without package downgrade
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 04 August 2019, 12:29 GMT
Reason for closing:  Fixed
Comment by eta (eeeeeta) - Saturday, 22 June 2019, 20:39 GMT
I've got the exact same problem; just ran $ pacman -Syu today and have this problem with mesa 19.1.0-3.
Comment by A.C. (zepar) - Saturday, 22 June 2019, 22:07 GMT
Same problem with mpv after the mesa upgrade
Comment by AK (Andreaskem) - Sunday, 23 June 2019, 08:37 GMT
Probably:
https://bugs.freedesktop.org/show_bug.cgi?id=110783

A fix does exist but has not been merged, yet, as far as I can tell:
https://gitlab.freedesktop.org/mesa/mesa/merge_requests/1084
Comment by Julio (The_Loko) - Friday, 19 July 2019, 21:11 GMT
Seems to be fixed with mesa 19.1.2

Loading...