Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62960 - [virt-manager] 2.2.0-1 missing gtksourceview4 dependency

Attached to Project: Community Packages
Opened by Jay (GSF1200S) - Friday, 21 June 2019, 07:16 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Sunday, 23 June 2019, 09:42 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Rebischke (Shibumi)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Description:
Virt-manager itself opens, and allows you to run machines or perform maintenance with the control panel. Attempting to spawn a VM window (to actually view the console or details) however doesn't work. virt-manager --debug spits out the following error:

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/manager.py", line 489, in row_activated
self.show_vm(_src)
File "/usr/share/virt-manager/virtManager/manager.py", line 474, in show_vm
vmmenu.VMActionUI.show(self, self.current_vm())
File "/usr/share/virt-manager/virtManager/vmmenu.py", line 329, in show
from .vmwindow import vmmVMWindow
File "/usr/share/virt-manager/virtManager/vmwindow.py", line 15, in <module>
from .details.details import vmmDetails
File "/usr/share/virt-manager/virtManager/details/details.py", line 18, in <module>
from ..addhardware import vmmAddHardware
File "/usr/share/virt-manager/virtManager/addhardware.py", line 23, in <module>
from .device.fsdetails import vmmFSDetails
File "/usr/share/virt-manager/virtManager/device/fsdetails.py", line 14, in <module>
from ..storagebrowse import vmmStorageBrowser
File "/usr/share/virt-manager/virtManager/storagebrowse.py", line 11, in <module>
from .hoststorage import vmmHostStorage
File "/usr/share/virt-manager/virtManager/hoststorage.py", line 17, in <module>
from .createpool import vmmCreatePool
File "/usr/share/virt-manager/virtManager/createpool.py", line 18, in <module>
from .xmleditor import vmmXMLEditor
File "/usr/share/virt-manager/virtManager/xmleditor.py", line 6, in <module>
gi.require_version('GtkSource', '4')
File "/usr/lib/python3.7/site-packages/gi/__init__.py", line 129, in require_version
raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace GtkSource not available

Installing gtksourceview4 from the extra repository solves this problem (everything works fine). The prior virt-manager version (2.1.0-2) does not need gtksourceview4 installed to function, so this appears to be a new required dependency for virt-manager 2.2.0.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

As above: open virt-manager 2.2.0 and it loads, but will not load a console/details window of any VM. Installing gtksourceview4 resolves this issue, and it is not listed as a dependency or optional dependency for virt-manager 2.2.0.
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Sunday, 23 June 2019, 09:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  virt-manager 2.2.0-2
Comment by Daniel Wendler (BMRMorph) - Friday, 21 June 2019, 08:00 GMT
It seems this dependency was added because of the "libvirt XML viewing and editing UI for new and existing domain, pools, volumes, networks".
The last virt-manager release only supports gtksourceview4 but in git the code it seems that the next version could also run with gtksourceview3.
Comment by Filipp Andjelo (scorp) - Sunday, 23 June 2019, 08:02 GMT
+1 here, I was surprised today by unusable virt-manager. Took some time to understand, what's happening.

Loading...