Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62952 - [rust] build doesn't respect MAKEFLAGS

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Thursday, 20 June 2019, 11:35 GMT
Last edited by Johannes Löthberg (demize) - Monday, 24 February 2020, 19:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Johannes Löthberg (demize)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

python ./x.py build -j"$(nproc)"

So, if I run a build slave and want to limit the parallelism
with MAKEFLAGS, then this is ignored and my machine gets hell
of a load. :-)

This leads to another issue, MAKEFLAGS is read by 'make' only,
so what about:
- ninja
- meson
- "fill in the new shiny build tool of the day"

Additional info:
* package version(s): 1.35.0-1

Steps to reproduce:
Build the package, look at top. :-)
This task depends upon

Closed by  Johannes Löthberg (demize)
Monday, 24 February 2020, 19:09 GMT
Reason for closing:  Not a bug
Additional comments about closing:  rustbuild is not make, so I will not pass $MAKEFLAGS to it.

Until either makepkg gets some way to specify the number of jobs generically, or until upstream decides to implement a subset of $MAKEFLAGS parsing, nothing can really change here.

Loading...