Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62876 - mouse scroll not working on kernel 4.19.46-1-lts and onwards

Attached to Project: Arch Linux
Opened by Claude (cezarclaude) - Tuesday, 11 June 2019, 22:06 GMT
Task Type Bug Report
Category Packages: Core
Status Unconfirmed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 2
Private No

Details

Description:
Mouse scroll stopped working after one of latest system updates. It is not working at all in any application. I tried command which shows mapping of all buttons in mouse and it looks like mouse scroll is not visible for system at all (3rd button is detected but scroll not) I tried change xorg.conf options but result of any change is that computer stop during boot. Below is my 40-libinput.conf mouse section with options what I tried to on.

Section "InputClass"
Identifier "libinput pointer catchall"
#Identifier "mouse0"
#Name "A4Tech PS/2+USB Mouse"
MatchIsPointer "on"
MatchDevicePath "/dev/input/event4"
#MatchDevicePath "/dev/input/mouse0"
#ZAxisMapping "4 5"
#Buttons "6"
Driver "libinput"
#Driver "evdev"
EndSection

orginally option MatchDevicePath was "/dev/input/event*"
I got 50-vmmmouse.conf in system as well:

Section "InputClass"
Identifier "vmmouse"
MatchIsPointer "on"
MatchTag "vmmouse"
Driver "vmmouse"
EndSection

this is rersult of egrep "Name|Handlers" /proc/bus/input/devices | egrep -B1 'Handlers.*mouse' command

N: Name="A4Tech PS/2+USB Mouse"
H: Handlers=event4 mouse0

Kernel 4.19.49-1 LTS

Scroll is working normally on kernel version 4.19.37-1 LTS

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Comment by Semyon (PocketSam) - Monday, 15 July 2019, 13:30 GMT
Same problem for me and another user.
https://bbs.archlinux.org/viewtopic.php?pid=1854196
Comment by loqs (loqs) - Monday, 15 July 2019, 22:27 GMT
Have you reported the issue upstream or determined which commit was the cause?
Comment by Semyon (PocketSam) - Tuesday, 16 July 2019, 05:08 GMT
Can you tell me how to determine which commit was the cause? Probably there is a step by step guide somewhere. I've never done it before. =\
Comment by loqs (loqs) - Wednesday, 17 July 2019, 00:24 GMT
First can you determine if any of the kernels between 4.19.37-1 and 4.19.49-1 were affected? If you do not have the packages required you can obtain them from [1].

[1] https://wiki.archlinux.org/index.php/Arch_Linux_Archive
Comment by Semyon (PocketSam) - Friday, 19 July 2019, 07:31 GMT
Seems like it's related to upstream bug https://bugzilla.kernel.org/show_bug.cgi?id=204179
Comment by Claude (cezarclaude) - Wednesday, 24 July 2019, 22:27 GMT
It looks like zen kernel is affected with same issue I got installed 5.2.2 and mouse stopped working from version 5.2.1.
Comment by loqs (loqs) - Thursday, 25 July 2019, 00:11 GMT
https://patchwork.kernel.org/patch/10986697/ applied to 4.19.60
@cezarclaude FS#63211 for linux-zen / linux
Edit:
I believe the causal commit was f7ab4818f74e4d7e796b59fe847de12beb7063b3 which was added in v4.19.44
Comment by Claude (cezarclaude) - Thursday, 25 July 2019, 08:12 GMT
I know about this patch, and this patch is working well but I have no idea how I can apply this patch, I did not try to do it, simply I did have got any problems with hardware on Arch yet. If You got any tutorial how to apply patch I would be very thankful.
Comment by loqs (loqs) - Thursday, 25 July 2019, 10:19 GMT
Patch applied as documented in [1], src.tar.gz with patch applied included for easy build testing.

[1] https://wiki.archlinux.org/index.php/Patching_packages#Applying_patches
Comment by Claude (cezarclaude) - Thursday, 25 July 2019, 23:00 GMT
Thank You so much for file. You are live saver. Thank You
Comment by Claude (cezarclaude) - Sunday, 28 July 2019, 18:50 GMT
Hi. I tried to do something with this files but as I said this is my first time when I need to do it and I have no completely idea how to do it. Would be possible to write me what commands I have to use to apply this patch please? Thank You in advance.
Comment by loqs (loqs) - Sunday, 28 July 2019, 20:08 GMT
Summarizing [1]

pacman -S base-devel # install the base tools group
bsdtar -xf linux-lts-4.19.60-1.src.tar.gz
cd linux-lts
makepkg -rsi #this make take a very long time

[1] https://wiki.archlinux.org/index.php/Makepkg#Usage
Comment by Claude (cezarclaude) - Wednesday, 31 July 2019, 14:17 GMT
Thank You very much took long time , but mouse work perfectly. Thank You once again.

Loading...