Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62846 - python-pytorch-cuda 1.1.0-1 expects protobuf 3.6.1

Attached to Project: Community Packages
Opened by Aleksandr Dubinsky (adfjjv) - Saturday, 08 June 2019, 18:50 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 19 June 2019, 04:32 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Konstantin Gizdov (kgizdov)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

There's been a change to the pytorch package so that it uses system protobuf. Previously, it used and bundled its own protobuf including protoc. The problem is that it still compiles itself against its own version, and then breaks when it's told to use system libraries. It expects protobuf 3.6.1 but Arch is at 3.7.0. I don't know what exactly is going on or how to fix it, but now I receive:

[libprotobuf FATAL google/protobuf/stubs/common.cc:86] This program was compiled against version 3.6.1 of the Protocol Buffer runtime library, which is not compatible with the installed version (3.7.0). Contact the program author for an update.

I have a version of pytorch 1.1.0 that I built using an earlier version of PKGBUILD, and it works. I've tried rebuilding python-pytorch-cuda with the current PKGBUILD and the problem remains. All other packages are up-to-date.

Unfortunately, I cannot share a short example that reproduces the problem. It happens in my data loader.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 19 June 2019, 04:32 GMT
Reason for closing:  Fixed
Comment by Aleksandr Dubinsky (adfjjv) - Saturday, 08 June 2019, 20:51 GMT
It seems to be enough to leave option BUILD_CUSTOM_PROTOBUF set to ON. Then, protoc is installed in `/usr/lib/python3.7/site-packages/torch/bin/protoc` and things work.
Comment by Aleksandr Dubinsky (adfjjv) - Monday, 10 June 2019, 12:21 GMT
Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 16 June 2019, 02:16 GMT
Please check rel -4.

Loading...