Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62809 - [wlroots] missing RDP backend

Attached to Project: Community Packages
Opened by Hannes Doyle (marulkan) - Tuesday, 04 June 2019, 11:20 GMT
Last edited by Brett Cornwall (ainola) - Wednesday, 16 October 2019, 14:54 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Brett Cornwall (ainola)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
When package is built it's missing build dependency freerdp so meson builds the package without RDP support.

Additional info:
* wlroots 0.6.0-1

Steps to reproduce:
Install package and try to follow these steps [1] [2], it will throw an error about RPD backend not available.
To get a working version build the package on a machine which has freerdp installed.

This task is more to notify about the issue than anything else since the RDP backend still feels a bit flaky.

[1] https://github.com/swaywm/wlroots/blob/master/docs/env_vars.md#rdp-backend
[2] https://drewdevault.com/2019/04/23/Using-cage-for-a-seamless-RDP-Wayland-desktop.html
This task depends upon

Closed by  Brett Cornwall (ainola)
Wednesday, 16 October 2019, 14:54 GMT
Reason for closing:  Implemented
Additional comments about closing:  sway 1:1.2-5 has the RDP backend enabled. Thanks for bringing this up!
Comment by David Runge (dvzrv) - Sunday, 09 June 2019, 20:03 GMT
I've just attempted to start sway with the RDP backend in wlroots.
I even rebuilt freerdp first, enabling all available optional components.

However, it segfaults every time. I've attached a verbos debug log, which suggests, that something goes wrong on binding the wl_display:

2019-06-09 19:19:36 - [wlroots-0.6.0/render/gles2/renderer.c:360] failed to bind wl_display to EGL

I assume this is part of the problem, as I don't see this message in the log, when starting without the RDP backend.
Comment by Brett Cornwall (ainola) - Friday, 21 June 2019, 18:00 GMT
I spoke with Drew (the upstream maintainer of wlroots) and he said "The RDP backend is basically proof-of-concept tier. The next release should fix the problem you're experiencing, though."

So I would imagine it unwise to enable this at the present time.
Comment by Brett Cornwall (ainola) - Tuesday, 08 October 2019, 02:12 GMT
I've built the newest 0.8.1 wlroots with the RDP backend enabled and pushed to [community-testing]. dvzrv, marulkan: Wanna help test to see if it's ready for enabling? :)

Loading...