Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62804 - [grub-customizer] Doesn't remove grub menu and timeout when set to do so

Attached to Project: Community Packages
Opened by Radoslav Nenchovski (rado84) - Monday, 03 June 2019, 20:07 GMT
Last edited by David Runge (dvzrv) - Monday, 02 September 2019, 22:17 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I used to have Windows along with Arch but then I erased Windows, so I didn't need Windows in the grub menu anymore. So I set grub-customizer not to display grub menu, disabled os-prober and timeout and saved the configuration. But despite my settings the grub menu is still being displayed and on top of that the timeout is still there - 4 seconds (initial timer set by me when I used to have dual boot). I clicked the Advanced settings button and discovered that grub_timeout is still 4 seconds (see the screenshot; sorry for the Bulgarian interface).
I unchecked the check boxes at first and when that didn't help, I entered 0 (zero) manually for the timeout but that didn't help either. But the grub menu still remained visible along with the timeout.

Additional info:
* package version(s): 5.1.0-1
* config and/or log files etc. - screenshot of config attached
* link to upstream bug report, if any

Steps to reproduce:
1. Have dual boot with Windows.
2. Remove Windows from grub menu.
3. Disable displaying of grub menu.
4. Make timeout 0 seconds and update config.
5. Reboot.
6. You'll see grub menu and timeout are still displayed, despite your settings.
This task depends upon

Closed by  David Runge (dvzrv)
Monday, 02 September 2019, 22:17 GMT
Reason for closing:  Upstream
Comment by David Runge (dvzrv) - Saturday, 31 August 2019, 23:49 GMT
@rado84: Thanks for the report!
It sounds like grub-customizer didn't run grub-mkconfig. You could do that manually as a test (e.g. grub-mkconfig -o /boot/grub/grub.cfg)
Comment by Radoslav Nenchovski (rado84) - Sunday, 01 September 2019, 14:59 GMT
That seems to work but I found another bug in the process: in the general settings tab "boot default entry after X seconds" - if I enter a number in the box, it's not accepted by GC (for instance if I enter 8 and then click "save", 8 changes to the previous number). The only way to have it accepted is to open advanced settings, check "Grub_Timeout" and manually enter the desired number.
Comment by David Runge (dvzrv) - Sunday, 01 September 2019, 18:12 GMT
Hm, I've just checked this (I don't have a dual boot setup with Windows though) and was able to set the timeout just fine and save the configuration.
Can you check, if you see anything out of the ordinary in the terminal, when doing the aforementioned steps after starting grub-customizer in a terminal?
Comment by Radoslav Nenchovski (rado84) - Monday, 02 September 2019, 13:01 GMT
I just reinstalled Arch cuz it was stuck with 5.2.7 kernel and now (with 5.2.11) this number changes normally. But the original bug report still stands - menu won't be removed and the only way to get rid of it is to enable the hidden menu.
Comment by David Runge (dvzrv) - Monday, 02 September 2019, 22:17 GMT
> menu won't be removed and the only way to get rid of it is to enable the hidden menu.

I think that is intentional. At any rate, I believe this to be not a bug with the package, but most likely a usability problem.

Please feel free to report this upstream [1]. Thanks!

[1] https://launchpad.net/grub-customizer

Loading...