Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62790 - [linux] USB ethernet module AX88772A not detected by kernel 5.1.6.arch1-1

Attached to Project: Arch Linux
Opened by Chih-Hsuan Yen (yan12125) - Saturday, 01 June 2019, 07:53 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 10 July 2019, 09:16 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
I have an USB ethernet module. lspci output:

Bus 001 Device 007: ID 0b95:772a ASIX Electronics Corp. AX88772A Fast Ethernet

It works fine up to 5.1.5.arch1-2. With 5.1.6.arch1-1, I can't find any ethernet interface in `ip addr`.

Looks like the USB ethernet module is using asix.ko:

$ ll /sys/class/net/enp0s20u2u4/device/driver/module
lrwxrwxrwx 1 root root 0 2019/06/01 15:47:08 /sys/class/net/enp0s20u2u4/device/driver/module -> ../../../../module/asix

In kernel 5.1.5.arch1-2, there is /lib/modules/5.1.5-arch1-2-ARCH/kernel/drivers/net/usb/asix.ko.xz, but the module is gone in 5.1.6.arch1-1. There is /usr/lib/modules/5.1.6-arch1-1-ARCH/kernel/drivers/net/phy/asix.ko.xz but it looks like a different module.

Additional info:
testing/linux 5.1.6.arch1-1

Steps to reproduce:
1. Upgrade the system
2. Reboot
3. Check network connections
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 10 July 2019, 09:16 GMT
Reason for closing:  Fixed
Comment by Chih-Hsuan Yen (yan12125) - Saturday, 01 June 2019, 12:59 GMT
This commit from OpenSUSE fixes my USB ethernet module: https://github.com/openSUSE/kernel/commit/a4ccfb2e71171aa0ab260bb111990b973da3eac3.

Looks like this patch is not applied on any repo on git.kernel.org yet. The latest thread on kernel mailing lists I can find starts from https://www.spinics.net/lists/netdev/msg570884.html.
Comment by Thomas Pointhuber (pointhi) - Wednesday, 05 June 2019, 07:18 GMT
Noticed the same issue with ```ASIX Electronics Corp. AX88772B```
Comment by Yuqian Yang (crupest) - Wednesday, 05 June 2019, 15:52 GMT
Now the 5.1.6-arch1-1-ARCH has released into stable respository but the bug remains.
Comment by Yuqian Yang (crupest) - Thursday, 06 June 2019, 07:11 GMT
The bug seems to have been fixed in 5.1.7-arch1-1-ARCH.
Comment by Chih-Hsuan Yen (yan12125) - Thursday, 06 June 2019, 10:07 GMT
Well, it works, but not _fixed_. The bug is a race condition in KBuild. See https://lkml.org/lkml/2019/5/15/120 for relevant discussions.
Comment by loqs (loqs) - Thursday, 13 June 2019, 20:58 GMT Comment by Chih-Hsuan Yen (yan12125) - Thursday, 20 June 2019, 04:38 GMT

Loading...