Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62788 - [mdadm] 4.1-1 cannot boot with a degraded array

Attached to Project: Arch Linux
Opened by Austin (heptagram) - Saturday, 01 June 2019, 03:21 GMT
Task Type Bug Report
Category Packages: Core
Status Unconfirmed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

mdadm 4.1-1 won't boot a degraded array. mdadm 4.0-2 is fine.

Two months ago (March 25-ish) I upgraded a drive by powering down, swapping, booting, then adding the new drive to my md arrays. This week I tried the same procedure and the system couldn't boot because the md devices weren't being assembled. I found I'd upgraded mdadm (4.0-2 -> 4.1-1) on April 19. Downgrading mdadm 4.1-1 -> 4.0-2 allowed the system to boot and let me to complete the swap.

Here's my mkinitcpio.conf HOOKS:

HOOKS=(base udev autodetect modconf block mdadm lvm2 usr filesystems keyboard fsck)

I tried mdadm_udev and saw no difference. I switched back to mdadm because that was what I was using prior. Idea being to test one change at a time.

My /boot is on a raid1, / is on raid5+lvm. lsblk is attached.
This task depends upon

Comment by eaut (eaut) - Thursday, 05 September 2019, 21:58 GMT
I have already posted the needed bug fix in FS#57860

Loading...