Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62739 - [file] 5.37-1 breaks svnserver and maybe some other packages

Attached to Project: Arch Linux
Opened by Sergej Pupykin (sergej) - Saturday, 25 May 2019, 09:33 GMT
Last edited by freswa (frederik) - Saturday, 22 February 2020, 22:07 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Steps to reproduce:

$ svnserve
svnserve: Relink `/usr/lib/libmagic.so.1' with `/usr/lib/libpthread.so.0' for IFUNC symbol `vfork'
You must specify exactly one of -d, -i, -t or -X.
Type 'svnserve --help' for usage.

> svnserve: Relink `/usr/lib/libmagic.so.1' with `/usr/lib/libpthread.so.0' for IFUNC symbol `vfork'

This message breaks svn clients when svnserve was started by xinetd.

$ svn up
Updating '.':
svn: E170013: Unable to connect to a repository at URL 'svn://...'
svn: E210004: Malformed network data

Downgrading to file 5.36 fixes this problem.
This task depends upon

Closed by  freswa (frederik)
Saturday, 22 February 2020, 22:07 GMT
Reason for closing:  None
Additional comments about closing:  This seems pretty stalled to me. If it's still an issue, please fill a re-open request. Thank you :)

Loading...