Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62722 - [nfs-utils] toplevel pkgdesc missing?

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Thursday, 23 May 2019, 15:08 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 24 May 2019, 04:16 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Checking PKGBUILD
PKGBUILD (nfs-utils) E: Missing description in PKGBUILD

Shouldn't a toplevel pkgdesc exists always?

Additional info:
* package version(s): 2.3.4-1


This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 24 May 2019, 04:16 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Thursday, 23 May 2019, 15:14 GMT
There's no such thing as a "top-level" pkgdesc. PKGBUILDs produce 1 to many packages, each with their own metadata. If you have a pkgdesc= declared in the global scope, it's implicitly inherited by any package_foopkg() function which doesn't declare it on its own. If every package_*() function in a PKGBUILD defines pkgdesc= on its own, then there's no point in including a pkgdesc= in the global scope.

namcap is simply wrong here.

Loading...