Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62713 - [glew-wayland] should not provide glew

Attached to Project: Community Packages
Opened by Benoit Brummer (trougnouf) - Wednesday, 22 May 2019, 20:15 GMT
Last edited by Alexander F. Rødseth (xyproto) - Thursday, 20 June 2019, 16:55 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Andreas Radke (AndyRTR)
Alexander F. Rødseth (xyproto)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I get the following error when trying to open openscad:

openscad: symbol lookup error: /usr/lib/libopencsg.so.1: undefined symbol: __glewXGetFBConfigAttribSGIX

package version 2019.05-1
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Thursday, 20 June 2019, 16:55 GMT
Reason for closing:  Implemented
Comment by Benoit Brummer (trougnouf) - Wednesday, 22 May 2019, 20:31 GMT
PKGBUILD fails with

/usr/bin/ld: objects/src/GLView.o: in function `GLView::enable_opencsg_shaders()':
GLView.cc:(.text+0x4db): undefined reference to `__GLXEW_SGIX_pbuffer'
/usr/bin/ld: GLView.cc:(.text+0x4e7): undefined reference to `__GLXEW_SGIX_fbconfig'
/usr/bin/ld: /usr/lib/libopencsg.so: undefined reference to `__glewXCreateGLXPbufferSGIX'
/usr/bin/ld: /usr/lib/libopencsg.so: undefined reference to `__glewXDestroyGLXPbufferSGIX'
/usr/bin/ld: /usr/lib/libopencsg.so: undefined reference to `__glewXGetVisualFromFBConfig'
/usr/bin/ld: /usr/lib/libopencsg.so: undefined reference to `__glewXGetFBConfigAttribSGIX'
/usr/bin/ld: /usr/lib/libopencsg.so: undefined reference to `__glewXGetCurrentDisplay'
/usr/bin/ld: /usr/lib/libopencsg.so: undefined reference to `__glewXCreateContextWithConfigSGIX'
/usr/bin/ld: /usr/lib/libopencsg.so: undefined reference to `__GLXEW_NV_float_buffer'
/usr/bin/ld: /usr/lib/libopencsg.so: undefined reference to `__glewXChooseFBConfigSGIX'
collect2: error: ld returned 1 exit status
make: *** [Makefile:910: openscad] Error 1
Comment by Antonio Rojas (arojas) - Wednesday, 22 May 2019, 20:32 GMT
pacman -Qs glew ?
Comment by Antonio Rojas (arojas) - Wednesday, 22 May 2019, 20:57 GMT
Can reproduce with glew-wayland - so glew-wayland does not really provide glew
Comment by Alexander F. Rødseth (xyproto) - Friday, 24 May 2019, 14:39 GMT
Thanks for reporting, I'll look into this.
Comment by Antonio Rojas (arojas) - Saturday, 25 May 2019, 08:41 GMT
Something similar to the glfw package is probably the best solution: rename glew to glew-x11, have it provide glew, and then packages that only work with one implementation can adjust their dependencies accordingly
Comment by Alexander F. Rødseth (xyproto) - Tuesday, 28 May 2019, 09:29 GMT
Since "glew" is not interchangeable, and some packages may need "glew-x11" while other packages may need "glew-wayland", perhaps the best move is to abandon the "glew" package name and require all packages to specify either "glew-x11" or "glew-wayland".

Either that, or just use "glew" as the "glew-x11" name, but that has the potential of being confusing as wayland grows in popularity.

I'll add andytr to this ticket. @andytr, what do you think?
Comment by Renato Caldas (rmsc) - Friday, 07 June 2019, 15:41 GMT
I've upvoted this issue, had to replace glew-wayland with glew to get Openscad to work. Now sway doesn't show the wallpaper (which I can live with, for now).
Comment by Andreas Radke (AndyRTR) - Friday, 07 June 2019, 19:48 GMT
Looking at upstream glew github commits it seem the ELG stuff is far from fully working and disabled for some builds.

I wonder if any wayland component or application should really depend on it. So far Fedora and Debian seem to work well without the glew egl built lib.
I suggest we try to get a clear statement from upstream what a distribution should build and ship for its users now. Maybe we have react to fast at  FS#56025  - Shipping two conflicting versions is no option until they are not fully compatible. At least both packages should be built out of one PKGBUILD by one maintainer to have an eye at all issues.

For this issue here I guess the egl build is broken here not sure it has been fixed with latest git commits (2.2.0 seems not far away) - maybe open another upstream issue at https://github.com/nigels-com/glew/issues if this also happens with latest git commits.
Comment by Renato Caldas (rmsc) - Wednesday, 12 June 2019, 13:18 GMT
As an additional note, with plain glew I can also run KiCad under wayland without the constant glitches and crashes. People were blaming wxGtk, but it may well be that glew's EGL backend is not yet ready.
Comment by Alexander F. Rødseth (xyproto) - Thursday, 20 June 2019, 16:54 GMT
Thank you for the feedback. Perhaps the next version of glew-wayland from upstream will support more applications.

I'm removing "provides=(glew)". The updated package will appear in [community] shortly.

Loading...