Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62712 - [python-wxpython] Multiple files are unreadable by group and world

Attached to Project: Community Packages
Opened by Klaus Alexander Seistrup (kseistrup) - Wednesday, 22 May 2019, 19:17 GMT
Last edited by Filipe Laíns (FFY00) - Wednesday, 22 May 2019, 19:47 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Morten Linderud (Foxboron)
Filipe Laíns (FFY00)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Several files in python-wxpython 4.0.5-2 are readable only by the owner (root), thus rendering the package unusable. Not only that, since /usr/lib/python3.7/site-packages/wxPython-4.0.5-py3.7.egg-info/PKG-INFO is also only readable by root, apps that don't even use wxpython, e.g. community/synapse, fails to start.

Additional info:
* package version(s)

4.0.5-2

* config and/or log files etc.

May 22 21:02:47 home synapse[11713]: PermissionError: [Errno 13] Permission denied: '/usr/lib/python3.7/site-packages/wxPython-4.0.5-py3.7.egg-info/PKG-INFO'

* link to upstream bug report, if any

Steps to reproduce:

$ sudo find /usr/lib/python3.7/site-packages/wx \! -perm -g+r | wc -l
110
This task depends upon

Closed by  Filipe Laíns (FFY00)
Wednesday, 22 May 2019, 19:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-wxpython 4.0.5-3

Loading...