Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62705 - [thunar] Regression, Thunar no longer works with WebDAV servers that do not support file locking.

Attached to Project: Arch Linux
Opened by Lance (Raansu) - Wednesday, 22 May 2019, 11:12 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 24 May 2019, 04:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: There seems to be a regression with Thunar. In the latest version of Thunar, trying to use the WebDAV function of Thunar (davs://) I will get a error message "The destination is read-only" trying to copy or move files from outside of a WebDAV mount. But I am able to move, copy, create new folders, create new empty files, and delete while working inside a WebDAV mount.

This issue appears to be entirely with Thunar. The server I was attempting with is a personal server running Nextcloud, Apache, MariaDB/MySQL, Redis, PHP, and PHP-FPM. I originally thought it to be a possible issue or configuration blunder with my server. But after some checking with the server and logs in use there seems to be no error messages relating to WebDAV. So I tried using a different client, "davfs2" (https://wiki.archlinux.org/index.php/Davfs2), and that works fine. I can read-write and copy or move files from outside of the WebDAV mount with davfs2.

I think it might have to do with the fact that as of May 22, 2019 the current Nextcloud implementation of WebDAV support does not support file locking. I get the following message from davfs2. "/usr/bin/mount.davfs: warning: the server does not support locks" But despite that davfs2 works fine.



After downgrading and testing different versions I found the following seems to be true on my system.

This affects the following Arch Linux package versions: thunar-1.8.6-1 and thunar-1.8.5-1

Last known good Arch Linux Package version: thunar-1.8.4-2
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 24 May 2019, 04:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  Reverted the offending commit in thunar 1.8.6-2.
Comment by Lance (Raansu) - Wednesday, 22 May 2019, 12:55 GMT
Seems related to this upstream bug I found already reported. https://bugzilla.xfce.org/show_bug.cgi?id=15367

Loading...