Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62666 - [linux-firmware] linux-lts doesn't boot after upgrade to 20190514.711d329-1

Attached to Project: Arch Linux
Opened by Alexander Mezin (Sanya_M) - Friday, 17 May 2019, 18:51 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 20 July 2019, 17:11 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
With linux-firmware 20190514.711d329-1 and linux-lts 4.19.44-1, system doesn't boot
When downgraded to linux-firmware 20190424.4b6cf2b-1, the system boots fine (with linux-lts 4.19.44-1 and linux-lts 4.19.43-1)
linux 5.1.2-1, linux 5.1.3-1 boots fine with any firmware version

The cause seems to be amdgpu firmware. Monitor just turns off when the driver loads (early if the driver is added to initrd, later if it isn't). I can't access the machine over SSH, so I assume that it doesn't boot. journald doesn't record anything

Additional info:
* linux-firmware 20190514.711d329-1
* GPU: Vega 10
* Upstream bug report: https://bugzilla.kernel.org/show_bug.cgi?id=203627
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 20 July 2019, 17:11 GMT
Reason for closing:  Fixed
Comment by loqs (loqs) - Friday, 17 May 2019, 20:50 GMT
Have you contacted Alexander Deucher?
amdgpu bugs would normally go to https://bugs.freedesktop.org/ Product: DRI Component: DRM/AMDgpu not sure if that applies to firmware issues.
Comment by Alexander Mezin (Sanya_M) - Wednesday, 22 May 2019, 21:54 GMT Comment by Alexander Mezin (Sanya_M) - Saturday, 20 July 2019, 14:11 GMT

Loading...