Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62663 - [mercurial] consider switching to python3

Attached to Project: Arch Linux
Opened by Emil (xexaxo) - Friday, 17 May 2019, 14:32 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 17 May 2019, 16:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

As you know better than me, mercurial 5.0 (in our repos) has (beta) support for python3.
Arch has always been proactive to using new features as they come out, so I would request if we can try python3.

Obviously if we spot multiple issues, the Arch devs can revert the package back to python2.
At the same time, the Arch community will actively debug and report python3 issues upstream.

Thanks
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 17 May 2019, 16:22 GMT
Reason for closing:  Not a bug
Additional comments about closing:  As documented on the mercurial wiki, this will 100% break all thirdparty extensions, *plus* this is a beta and just because Arch is rolling-release does not mean we package YOLO betas.

The mercurial release notes state that they expect many remaining bugs, and strongly discourages packagers from making python3 the default at this time.

Loading...