Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62649 - [qgis] missing dependency 'python-gdal'.

Attached to Project: Community Packages
Opened by Oid Maps (dreieck) - Thursday, 16 May 2019, 13:11 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 16 May 2019, 13:44 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The package community/qgis misses the dependency 'python-gdal' (it is listed as optional dependency, but seems to be mandatory for many basic or popular plugins like QuickOSM, so it should be mandatory):

Installing 'qgis', and then running it, gives the following error message(s) in a window:

```
Couldn't load plugin 'QuickOSM' due to an error when calling its classFactory() method

ModuleNotFoundError: No module named 'osgeo'
Traceback (most recent call last):
File "/usr/lib/python3.7/site-packages/qgis/utils.py", line 335, in startPlugin
plugins[packageName] = package.classFactory(iface)
File "/home/felics/.local/share/QGIS/QGIS3/profiles/default/python/plugins/QuickOSM/__init__.py", line 26, in classFactory
from .quick_osm import QuickOSMPlugin
File "/usr/lib/python3.7/site-packages/qgis/utils.py", line 672, in _import
mod = _builtin_import(name, globals, locals, fromlist, level)
File "/home/felics/.local/share/QGIS/QGIS3/profiles/default/python/plugins/QuickOSM/quick_osm.py", line 30, in
from QuickOSM.quick_osm_processing.provider import Provider
File "/usr/lib/python3.7/site-packages/qgis/utils.py", line 672, in _import
mod = _builtin_import(name, globals, locals, fromlist, level)
File "/home/felics/.local/share/QGIS/QGIS3/profiles/default/python/plugins/QuickOSM/quick_osm_processing/provider.py", line 35, in
from QuickOSM.quick_osm_processing.advanced.build_query import (
File "/usr/lib/python3.7/site-packages/qgis/utils.py", line 672, in _import
mod = _builtin_import(name, globals, locals, fromlist, level)
File "/home/felics/.local/share/QGIS/QGIS3/profiles/default/python/plugins/QuickOSM/quick_osm_processing/advanced/build_query.py", line 21, in
from processing.algs.qgis.QgisAlgorithm import QgisAlgorithm
File "/usr/lib/python3.7/site-packages/qgis/utils.py", line 672, in _import
mod = _builtin_import(name, globals, locals, fromlist, level)
File "/usr/share/qgis/python/plugins/processing/__init__.py", line 28, in
from processing.tools.dataobjects import * # NOQA
File "/usr/lib/python3.7/site-packages/qgis/utils.py", line 672, in _import
mod = _builtin_import(name, globals, locals, fromlist, level)
File "/usr/share/qgis/python/plugins/processing/tools/dataobjects.py", line 51, in
from processing.algs.gdal.GdalUtils import GdalUtils
File "/usr/lib/python3.7/site-packages/qgis/utils.py", line 672, in _import
mod = _builtin_import(name, globals, locals, fromlist, level)
File "/usr/share/qgis/python/plugins/processing/algs/gdal/GdalUtils.py", line 38, in
from osgeo import ogr
File "/usr/lib/python3.7/site-packages/qgis/utils.py", line 672, in _import
mod = _builtin_import(name, globals, locals, fromlist, level)
ModuleNotFoundError: No module named 'osgeo'


Python version: 3.7.3 (default, Mar 27 2019, 19:19:44) [GCC 8.2.1 20181127]
QGIS version: 3.6.1-Noosa Noosa, exported

Python Path:
/usr/share/qgis/python
/home/felics/.local/share/QGIS/QGIS3/profiles/default/python
/home/felics/.local/share/QGIS/QGIS3/profiles/default/python/plugins
/usr/share/qgis/python/plugins
/usr/lib/python37.zip
/usr/lib/python3.7
/usr/lib/python3.7/lib-dynload
/usr/lib/python3.7/site-packages
/usr/lib/python3.7/site-packages/linkgrammar
/home/felics/.local/share/QGIS/QGIS3/profiles/default/python
```


Additional info:
* package version: qgis 3.6.1-1

Steps to reproduce:
* Install community/qgis and have python-gdal not installed.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 16 May 2019, 13:44 GMT
Reason for closing:  Not a bug
Additional comments about closing:  That's what optional deps are for

Loading...