Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62596 - [irssi-xmpp] Current build doesn't work with irssi 1.2.0

Attached to Project: Community Packages
Opened by Aleksei (nesk_bugs) - Friday, 10 May 2019, 20:47 GMT
Last edited by Balló György (City-busz) - Friday, 30 August 2019, 04:50 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

Description:
Getting this on startup:
23:28 -!- Irssi: xmpp/core is ABI version 13 but Irssi is version 20, cannot load
23:28 -!- Irssi: Error loading module xmpp/fe: /usr/lib/irssi/modules/libfe_xmpp.so: undefined symbol: xmpp_extract_resource
23:28 -!- Irssi: xmpp/core is ABI version 13 but Irssi is version 20, cannot load

Additional info:
* irssi 1.2.0-2, irssi-xmpp 0.54-2
* Older, but analogous upstream bug, looks like rebuilding fixed it: https://github.com/cdidier/irssi-xmpp/issues/33
* Debian recently had a bug with the same symptoms and the same version combination, they fixed it by rebuilding as well: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=925596

Steps to reproduce:
1) Install irssi 1.2.0-2, irssi-xmpp 0.54-2
2) Start irssi, type /LOAD xmpp
This task depends upon

Loading...