Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62587 - [mumble] The application does not start

Attached to Project: Community Packages
Opened by Jamison Nusbaum (maawie) - Friday, 10 May 2019, 07:54 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Thursday, 04 July 2019, 22:35 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
The application does not start

Additional info:
* package version(s): 1.3.0rc1-1

Log:
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
<W>2019-05-10 12:53:38.231 JackAudioSystem: unable to open client due to 2 errors:
<W>2019-05-10 12:53:38.231 JackAudioSystem: JackFailure - overall operation failed
<W>2019-05-10 12:53:38.231 JackAudioSystem: JackServerFailed - unable to connect to the JACK server

Steps to reproduce:
Open through terminal or shortcut.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Thursday, 04 July 2019, 22:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  Built without jack now until upstream fixes that.
Comment by Sven-Hendrik Haase (Svenstaro) - Friday, 17 May 2019, 02:11 GMT
Does it work if you remove jack?
Comment by Tom Ient (peanutbutter144) - Friday, 17 May 2019, 10:38 GMT
I'm getting the same problem. When jack is removed with pacman -Rdd, this error is produced:

mumble: error while loading shared libraries: libjack.so.0: cannot open shared object file: No such file or directory
Comment by Samuel Walladge (swalladge) - Saturday, 18 May 2019, 05:51 GMT
Appears to have been reported and fixed upstream: https://github.com/mumble-voip/mumble/issues/3682
Comment by Samuel Walladge (swalladge) - Saturday, 18 May 2019, 06:01 GMT
Can confirm that `mumble-git` from the aur works without segfaulting at this point in time.
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 20 May 2019, 04:50 GMT
Good catch. I asked them whether I can wait it out or whether I have to backport those patches.
Comment by Tom Ient (peanutbutter144) - Monday, 20 May 2019, 10:14 GMT
Comment by Sven-Hendrik Haase (Svenstaro) - Friday, 24 May 2019, 03:42 GMT
Please test rel -2.
Comment by Dietrich Hallentforden (aufkrawall) - Saturday, 25 May 2019, 22:30 GMT
rel -2 blocks any audio output (and probably input too) after starting Mumble. I tried the workaround described in the wiki for DeadBeef, but it doesn't help.
So I had to revert to previous package because this one is unusable for me.
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 27 May 2019, 19:28 GMT
I had to revert the patch. Not sure what to do now, though. I suppose we have to wait for the next release.
Comment by Sven-Hendrik Haase (Svenstaro) - Friday, 28 June 2019, 10:29 GMT
Please try the new rc2. It's now available in [community], too.
Comment by Dietrich Hallentforden (aufkrawall) - Friday, 28 June 2019, 10:38 GMT
It unfortunately still blocks audio completely, as does mumble-git from AUR.
Comment by Sven-Hendrik Haase (Svenstaro) - Friday, 28 June 2019, 11:03 GMT
Any suggestions on what to do here at this point? We've now got all the recent upstream fixes in the current [community] package and it still appears to cause problems for you. I'm not sure this can be fixed on a downstream packaging level. Can you bring the issue up with upstream once again now that you're using up-to-date code?
Comment by Dietrich Hallentforden (aufkrawall) - Friday, 28 June 2019, 11:28 GMT
It seems to be related to jack, I forcibly removed it, recompiled and now it works. So perhaps disabling jack support in mumble's compile config would be a proper workaround for the time being? I use a very typical PulseAudio default config for my system.
I'll report this issue upstream.

Edit: Issue is already known to the devs:
https://github.com/mumble-voip/mumble/issues/3694
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 01 July 2019, 23:13 GMT
Please post the upstream bug here.

Loading...