Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62584 - [modem-manager-gui] Segmentation fault at address: 0x8

Attached to Project: Community Packages
Opened by Zen Anon X (ZenAnonX) - Friday, 10 May 2019, 02:51 GMT
Last edited by Balló György (City-busz) - Wednesday, 19 June 2019, 17:57 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Balló György (City-busz)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
modem-manager-gui crashes with segmentation fault after recent updates.

Additional info:
* package version(s): 0.0.19.1-3

* log:
Connection manager: Network Manager >= 0.9.0
Modem manager: Modem Manager >= 0.7.0
Segmentation fault at address: 0x8
Stack trace:
1. /usr/lib/libc.so.6(+0xbd05a) [0x7fa0f330405a]
2. /usr/lib/libc.so.6(+0xbd05a) [0x7fa0f330405a]
3. /usr/lib/libc.so.6(strftime_l+0x2c) [0x7fa0f330634c]
4. modem-manager-gui(mmgui_str_format_sms_time+0xef) [0x55af10ef462f]
5. modem-manager-gui(+0x34105) [0x55af10f13105]
6. modem-manager-gui(mmgui_main_sms_list_fill+0x27e) [0x55af10f1601e]
7. modem-manager-gui(+0x48f95) [0x55af10f27f95]
8. modem-manager-gui(mmguicore_devices_open+0x1c5) [0x55af10f06895]
9. modem-manager-gui(+0x3a055) [0x55af10f19055]

Steps to reproduce:
Open modem-manager-gui through terminal or shortcut.
This task depends upon

Closed by  Balló György (City-busz)
Wednesday, 19 June 2019, 17:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  modem-manager-gui 0.0.19.1-4
Comment by Alexander E. Patrakov (patrakov) - Monday, 03 June 2019, 12:46 GMT
Confirmed. For debugging, I have removed ~/.local/share/modem-manager-gui. Then modem-manager-gui starts, but displays all SMS times incorrectly (1970-01-01 04:59:59, my timezone is UTC+5, i.e. there is a "-1 second UTC" timestamp somewhere). If I send myself an SMS (from the phone to the modem), it arrives, but clicking on it yields the same crash.

As a workaround against the crash, I applied this patch, but it is obviously not a solution, because mmcli is able to retrieve the timestamp correctly

EDITED - patch has to be attached in order to avoid being damaged.
Comment by Alexander E. Patrakov (patrakov) - Monday, 03 June 2019, 12:46 GMT
Sending the workaround patch as an attachment.
Comment by Balló György (City-busz) - Wednesday, 19 June 2019, 16:49 GMT
Please test modem-manager-gui 0.0.19.1-4
Comment by Alexander E. Patrakov (patrakov) - Wednesday, 19 June 2019, 17:02 GMT
Tested.

It does not crash anymore, but obviously does not display the correct date of messages (the displayed date is one second before the Epoch).
Comment by Balló György (City-busz) - Wednesday, 19 June 2019, 17:08 GMT
I'm closing this task, since it's an upstream task, and I can't help.

You can contact with upstream here:
https://linuxonly.ru/forum/modem-manager-gui/

Loading...