Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62574 - vlc does not start with the --started-from-file flag

Attached to Project: Arch Linux
Opened by Cat (catwhistle) - Wednesday, 08 May 2019, 11:21 GMT
Last edited by Levente Polyak (anthraxx) - Wednesday, 08 May 2019, 20:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The default file is /usr/share/applications/vlc.desktop has the following startup line:
Exec=/usr/bin/vlc --started-from-file %U
But this command does not work and displays an error in strace. This problem now affects absolutely all users.

Additional info:
* vlc 3.0.6-11
* attach file

Steps to reproduce:
vlc --started-from-file [file]
   vlc.log (169 KiB)
This task depends upon

Closed by  Levente Polyak (anthraxx)
Wednesday, 08 May 2019, 20:01 GMT
Reason for closing:  Works for me
Comment by Levente Polyak (anthraxx) - Wednesday, 08 May 2019, 12:16 GMT
which part of strace do you refere to? It works for me so not sure what you mean.
run /usr/bin/vlc --started-from-file and pass %U yourself
Comment by Cat (catwhistle) - Wednesday, 08 May 2019, 16:49 GMT
> which part of strace do you refere to? It works for me so not sure what you mean.
> run /usr/bin/vlc --started-from-file and pass %U yourself

I wrote what I started the program and brought strace after that.
I run: /usr/bin/vlc --started-from-file b.mp4
Error at this point: EAGAIN (Resource temporarily unavailable)
I remove the parameter started-from-file and the video starts.
Comment by Levente Polyak (anthraxx) - Wednesday, 08 May 2019, 20:01 GMT
it works perfectly here and there is nothing related to this that is packaging related.
If you think this is a bug, report it upstream but is looks like a system configuration issue.

Loading...