Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62483 - [systemd] 242.0-3: Failed to update link state, ignoring: No data available

Attached to Project: Arch Linux
Opened by Eric Wang (enihcam) - Saturday, 27 April 2019, 01:58 GMT
Last edited by Christian Hesse (eworm) - Friday, 10 May 2019, 20:36 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Archlinux-based router stopped working after upgrade systemd from 241.93-1 to 242.0-3

Additional info:
* package version(s)
core/systemd 241.93-1 -> 242.0-3
core/systemd-libs 241.93-1 -> 242.0-3

* config and/or log files etc.
/etc/systemd/network $ cat *
[NetDev]
Name=br0
Kind=bridge

[Match]
Name=br0
[Network]
Address=192.168.1.1/24
Address=192.168.1.10/24
ConfigureWithoutCarrier=true
IPForward=ipv4
IPv6AcceptRA=no
LinkLocalAddressing=no
LLDP=false
LLMNR=false
MulticastDNS=true

[Match]
Driver=igb
[Link]
NamePolicy=kernel database onboard slot path
MACAddressPolicy=random
GenericReceiveOffload=true
GenericSegmentationOffload=true
LargeReceiveOffload=true
TCPSegmentationOffload=true
WakeOnLan=off

[Match]
Name=enp2s0 enp3s0 enp4s0 enp5s0 enp6s0
[Network]
Bridge=br0
ConfigureWithoutCarrier=true
IPv6AcceptRA=no
LinkLocalAddressing=no
LLDP=false
LLMNR=false

[Match]
Name=enp1s0
[Link]
Unmanaged=yes
RequiredForOnline=no
[Network]
ConfigureWithoutCarrier=true
IPv6AcceptRA=no
LinkLocalAddressing=no
LLDP=false
LLMNR=false

* link to upstream bug report, if any

Steps to reproduce:
Apr 27 09:36:41 router systemd-networkd[345]: br0: netdev ready
Apr 27 09:36:41 router systemd-networkd[345]: Enumeration completed
Apr 27 09:36:41 router systemd-networkd[345]: enp1s0: Interface name change detected, enp1s0 has been renamed to eth0.
Apr 27 09:36:41 router systemd-networkd[345]: enp2s0: Interface name change detected, enp2s0 has been renamed to eth1.
Apr 27 09:36:41 router systemd-networkd[345]: enp3s0: Interface name change detected, enp3s0 has been renamed to eth2.
Apr 27 09:36:41 router systemd-networkd[345]: enp4s0: Interface name change detected, enp4s0 has been renamed to eth3.
Apr 27 09:36:41 router systemd-networkd[345]: enp5s0: Interface name change detected, enp5s0 has been renamed to eth4.
Apr 27 09:36:41 router systemd-networkd[345]: enp6s0: Interface name change detected, enp6s0 has been renamed to eth5.
Apr 27 09:36:41 router systemd-networkd[345]: eth0: Interface name change detected, eth0 has been renamed to enp1s0.
Apr 27 09:36:41 router systemd-networkd[345]: eth4: Interface name change detected, eth4 has been renamed to enp5s0.
Apr 27 09:36:41 router systemd-networkd[345]: eth5: Interface name change detected, eth5 has been renamed to enp6s0.
Apr 27 09:36:41 router systemd-networkd[345]: eth2: Interface name change detected, eth2 has been renamed to enp3s0.
Apr 27 09:36:41 router systemd-networkd[345]: eth3: Interface name change detected, eth3 has been renamed to enp4s0.
Apr 27 09:36:41 router systemd-networkd-wait-online[348]: enp6s0: Failed to update link state, ignoring: No data available
Apr 27 09:36:41 router systemd-networkd-wait-online[348]: enp5s0: Failed to update link state, ignoring: No data available
Apr 27 09:36:41 router systemd-networkd-wait-online[348]: enp4s0: Failed to update link state, ignoring: No data available
Apr 27 09:36:41 router systemd-networkd-wait-online[348]: enp3s0: Failed to update link state, ignoring: No data available
Apr 27 09:36:41 router systemd-networkd-wait-online[348]: enp2s0: Failed to update link state, ignoring: No data available
Apr 27 09:36:41 router systemd-networkd-wait-online[348]: enp1s0: Failed to update link state, ignoring: No data available
Apr 27 09:36:41 router systemd-networkd[345]: eth1: Interface name change detected, eth1 has been renamed to enp2s0.
Apr 27 09:36:41 router systemd-networkd[345]: enp1s0: Gained carrier
Apr 27 09:36:41 router systemd-networkd[345]: Assertion 'link->network' failed at ../systemd-stable/src/network/networkd-link.c:1858, function link_acquire_ipv4_conf(). Aborting.
Apr 27 09:36:41 router systemd-networkd-wait-online[348]: enp6s0: Failed to update monitor information: No data available
Apr 27 09:36:41 router systemd-networkd-wait-online[348]: enp3s0: Failed to update monitor information: No data available
Apr 27 09:36:41 router systemd-networkd-wait-online[348]: enp5s0: Failed to update monitor information: No data available
Apr 27 09:36:41 router systemd-networkd-wait-online[348]: enp4s0: Failed to update monitor information: No data available
Apr 27 09:36:41 router systemd-networkd-wait-online[348]: enp2s0: Failed to update monitor information: No data available
Apr 27 09:36:41 router systemd[1]: systemd-networkd.service: Main process exited, code=killed, status=6/ABRT
Apr 27 09:36:41 router systemd[1]: systemd-networkd.service: Failed with result 'signal'.
This task depends upon

Closed by  Christian Hesse (eworm)
Friday, 10 May 2019, 20:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  systemd 242.29-1
2019-05-13: A request to re-open the task has been made. Reason for request: systemd 242.29-1 does not resolve the issue. The error messages are gone but squid and smb services starting time out
Comment by loqs (loqs) - Saturday, 27 April 2019, 12:43 GMT
Can you please report the issue upstream https://github.com/systemd/systemd/issues
Comment by Eric Wang (enihcam) - Sunday, 28 April 2019, 02:24 GMT Comment by loqs (loqs) - Sunday, 28 April 2019, 10:51 GMT
test.patch applies the commit from PR #12423
source bundle with patch applied for easy build testing.
Edit:
Now upstream as commit 51aba17b88617515e037e8985d3a4ea871ac47fe
Comment by Oleksandr Natalenko (post-factum) - Thursday, 02 May 2019, 21:23 GMT
I get the following:

systemd-networkd[743]: Assertion 'link->network' failed at ../systemd-stable/src/network/networkd-link.c:1203, function link_request_set_addresses(). Aborting.

Shouldn't this assertion be removed as well?
Comment by Herbert M. (seppel) - Friday, 03 May 2019, 09:47 GMT
Same problem here after system updating on 2. of may.

Mai 02 19:35:19 vserver systemd-networkd[355]: Assertion 'link->network' failed at ../systemd-stable/src/network/networkd-link.c:1858, function link_acquire_ipv4_conf(). Aborting.


With following dumped core

Mai 02 19:35:19 vserver systemd-coredump[377]: Process 355 (systemd-network) of user 981 dumped core.

Stack trace of thread 355:
#0 0x00007f367ade082f raise (libc.so.6)
#1 0x00007f367adcb672 abort (libc.so.6)
#2 0x00007f367ab5802c n/a (libsystemd-shared-242.so)
#3 0x0000555a2de313b2 n/a (systemd-networkd)
#4 0x0000555a2de2a8b8 n/a (systemd-networkd)
#5 0x0000555a2de5982d n/a (systemd-networkd)
#6 0x00007f367ab95963 sd_netlink_process (libsystemd-shared-242.so)
#7 0x00007f367ab95f14 n/a (libsystemd-shared-242.so)
#8 0x00007f367ab888ce n/a (libsystemd-shared-242.so)
#9 0x00007f367ab88ba3 sd_event_dispatch (libsystemd-shared-242.so)
#10 0x00007f367ab88d69 sd_event_run (libsystemd-shared-242.so)
#11 0x00007f367ab88f8c sd_event_loop (libsystemd-shared-242.so)
#12 0x0000555a2ddfe423 n/a (systemd-networkd)
#13 0x00007f367adccce3 __libc_start_main (libc.so.6)
#14 0x0000555a2ddfef6e n/a (systemd-networkd)

Network does not come up on boot. Manual intervention is needed to bring the network up with netctl.

This happend on a VPS at https://www.netcup.de.

If i revert to the system state to 25. April the problem is gone. Should be a problem with systemd.networkd or current kernel.

Best regards.
Comment by Oleksandr Natalenko (post-factum) - Friday, 03 May 2019, 10:11 GMT Comment by Oleksandr Natalenko (post-factum) - Friday, 03 May 2019, 16:17 GMT
Confirming https://github.com/systemd/systemd/pull/12466 as a fix for my issue. Please consider backporting both 51aba17b88 and #12466. Thanks.
Comment by loqs (loqs) - Saturday, 04 May 2019, 17:08 GMT
PR#12466 committed as 6450ee3f8c841dce72d8d5b986813bf2cf7dbdf8
Comment by Oleksandr Natalenko (post-factum) - Sunday, 05 May 2019, 10:37 GMT
To be more specific, it is b9ea3d2e47b3741f3f46ba9c5e19640136933b71.
Comment by Eric Wang (enihcam) - Monday, 06 May 2019, 00:18 GMT
When will it be backported? My router has been unusable since 10 days ago.

Loading...