Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62432 - [linux][linux-lts][linux-zen][linux-hardened] Disable userspace firmware loading

Attached to Project: Arch Linux
Opened by Corubba (corubba) - Monday, 22 April 2019, 13:23 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 11 December 2019, 07:21 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

5 years ago, systemd dropped support for userspace firmware loading (using udev). Since then, the README [0] recommends to disable the kernel option CONFIG_FW_LOADER_USER_HELPER. The current linux package version 5.0.8.arch1-1 [1] and linux-lts 4.19.34-1 [1] still have that option enabled.

For what it's worth, debian disabled that option years ago with bug #718975 [3].


[0] https://github.com/systemd/systemd/blame/master/README#L61
[1] https://git.archlinux.org/svntogit/packages.git/tree/trunk/config?h=packages/linux#n2065
[2] https://git.archlinux.org/svntogit/packages.git/tree/trunk/config?h=packages/linux-lts#n2053
[3] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=718975
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 11 December 2019, 07:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  now disabled in all the kernels.
Comment by Levente Polyak (anthraxx) - Tuesday, 30 July 2019, 20:57 GMT
Removed from systemd in https://github.com/systemd/systemd/commit/be2ea723b1d023b3d385d3b791ee4607cbfb20ca (not causing any delays like back then the debian bug report mentions).

affecting: vanilla, lts, zen, hardened

please take a look, however there is DELL_RBU and LEDS_LP55XX_COMMON selecting it
Comment by Andreas Radke (AndyRTR) - Friday, 06 September 2019, 19:55 GMT
disabled for LTS kernel in trunk now
Comment by Jan Alexander Steffens (heftig) - Monday, 18 November 2019, 21:26 GMT
Disabled in linux and linux-zen since 5.2.5.

Loading...