Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62415 - Avrdude 1:6.3-5 compiled without USB support

Attached to Project: Community Packages
Opened by José Jorge (mexchip) - Saturday, 20 April 2019, 21:27 GMT
Last edited by Jelle van der Waa (jelly) - Sunday, 12 May 2019, 11:00 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jelle van der Waa (jelly)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
After upgrading to version 1:6.3-5, it's not possible to use avrdude with an AVR Dragon programmer. avrdude shows this message when trying to communicate with AVR Dragon:

avrdude was compiled without usb support.

Going back to version 1:6.3-4 allows the use of AVR Dragon.

Steps to reproduce:
* Update avrdude to version 1:6.3-5.
* Execute the following (no need for an actual AVR Dragon programmer):

$ avrdude -c dragon_isp -p atmega8

This message appears:

avrdude was compiled without usb support.

avrdude done. Thank you.
This task depends upon

Closed by  Jelle van der Waa (jelly)
Sunday, 12 May 2019, 11:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 1:6.3-4
Comment by loqs (loqs) - Sunday, 21 April 2019, 00:13 GMT
stk500v2.c at least does not support libusb only libusb-compat.
Comment by Barry G (smartiq) - Monday, 22 April 2019, 17:56 GMT
Same issue here with the OLIMEX AVR-ISP-MK2. Downgraded to get it working again. Have both libusb and libusb-compat installed.
Comment by José Jorge (mexchip) - Wednesday, 24 April 2019, 14:58 GMT
I have both libusb and libusb-compat installed too:

$ pacman -Qsq libusb
libgusb
libusb
libusb-compat
libusbmuxd
Comment by loqs (loqs) - Wednesday, 24 April 2019, 17:17 GMT
Having libusb-compat installed is not enough. The functionality is disabled at build time see [1]

https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/avrdude&id=724dc5e4e8b576c356e22d08c087b2f81d849f23
Comment by Matt H (limaxray) - Saturday, 27 April 2019, 01:31 GMT
I can confirm avrdude still heavily targets libusb 0.1 so libusb-compat is a necessary dependency. Removing it from the depends list breaks support for most USB programmers.
Comment by Peter Hercek (phercek) - Thursday, 02 May 2019, 07:34 GMT
The same problem with AVR Dragon here as well.
Version 1:6.3-4 works.

Loading...