Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62383 - [pysolfc] 2.4.0-1 no longer runs

Attached to Project: Community Packages
Opened by NoobAlice (NoobAlice) - Thursday, 18 April 2019, 00:36 GMT
Last edited by Antonio Rojas (arojas) - Friday, 26 April 2019, 10:12 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 2
Private No

Details

Description:

As of sometime in the last few weeks, Pysolfc no longer runs at all for me. Clicking the icon in Xfce yields no result. Using the terminal:
$ pysol
Traceback (most recent call last):
File "/usr/bin/pysol", line 37, in <module>
from pysollib.main import main # noqa: E402
File "/usr/lib/python3.7/site-packages/pysollib/main.py", line 32, in <module>
from pysollib.util import DataLoader
File "/usr/lib/python3.7/site-packages/pysollib/util.py", line 30, in <module>
from pysollib.mfxutil import Image
File "/usr/lib/python3.7/site-packages/pysollib/mfxutil.py", line 54, in <module>
if TOOLKIT == 'tk' and Image and Image.VERSION >= '1.1.7':
AttributeError: module 'PIL.Image' has no attribute 'VERSION'

Pysolfc was last updated 2018-09-30, but its dependency python-pillow was just updated 2019-04-05. Maybe this is the cause?

I think I last played with Pysolfc in the first days of April. My last few full system updates and reboots were March 24, April 01, April 07, and today April 17.


Additional info:

* package version(s)
pysolfc 2.4.0-1
python-pillow 6.0.0-1

* Steps to reproduce:
Fully update system (pacmatic -Syu), then...
Click icon for Pysolfc
OR
Type "pysol" in terminal

* Maybe relevant:
I've never used pip or anything similar, just pacman (but pacman often via pacmatic).
This task depends upon

Comment by loqs (loqs) - Thursday, 18 April 2019, 23:12 GMT Comment by Dana (DJ9) - Sunday, 21 April 2019, 12:41 GMT
I'm getting the same error here.

Traceback (most recent call last):
File "/usr/bin/pysol", line 37, in <module>
from pysollib.main import main # noqa: E402
File "/usr/lib/python3.7/site-packages/pysollib/main.py", line 32, in <module>
from pysollib.util import DataLoader
File "/usr/lib/python3.7/site-packages/pysollib/util.py", line 30, in <module>
from pysollib.mfxutil import Image
File "/usr/lib/python3.7/site-packages/pysollib/mfxutil.py", line 54, in <module>
if TOOLKIT == 'tk' and Image and Image.VERSION >= '1.1.7':
AttributeError: module 'PIL.Image' has no attribute 'VERSION'

Matching additional info, but just did a fresh install and update early this morning.
Comment by Drew Ferguson (blacktav) - Friday, 26 April 2019, 10:00 GMT
There was a problem with the upstream source; but that has been fixed and the latest release builds & runs fine

However, our Arch package is still stuck at "out-of-date"

Loading...