Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62381 - [acpica][virtualbox] iasl from acpica >= 20190329 breaks Windows 7 virtual machines

Attached to Project: Community Packages
Opened by baggar11 (baggar11) - Wednesday, 17 April 2019, 22:40 GMT
Last edited by Chih-Hsuan Yen (yan12125) - Saturday, 11 May 2019, 00:44 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Laurent Carlier (lordheavy)
Christian Hesse (eworm)
Bruno Pagani (ArchangeGabriel)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 17
Private No

Details

Description: Upgraded to 6.0.6 and VM's failed to boot with an ACPI BIOS error. Issue was posted on the virtualbox forum from a couple other Arch users. https://forums.virtualbox.org/viewtopic.php?f=7&t=92709. One of the moderators noticed that our build(r129722) isn't the official build(r130049) that virtualbox posts on their site. I've attached my VBox.log file in hopes it will help.


Additional info:
* package version(s): virtualbox 6.0.6-1, virtualbox-host-dkms 6.0.6-1, virtualbox-guest-iso 6.0.6-1
* config and/or log files etc.: see attachment
* link to upstream bug report, if any

Steps to reproduce: Upgrade virtualbox to 6.0.6-1 and reboot. All VM's will be unable to boot. After rolling back to 6.0.4-1 and rebooting, VMs are bootable again.
This task depends upon

Closed by  Chih-Hsuan Yen (yan12125)
Saturday, 11 May 2019, 00:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  community/acpica 20190509-1
Comment by Sven (skoehler) - Wednesday, 17 April 2019, 22:52 GMT
Windows 10 and XP guests boot fine for me. Only my Windows 7 guests don't boot.
Link to discussion in virtualbox forum: https://forums.virtualbox.org/viewtopic.php?f=7&t=92709
Comment by baggar11 (baggar11) - Wednesday, 17 April 2019, 23:04 GMT
I guess I should define all VM's for me. I had Ubuntu guests that didn't boot, but now that I think about it, I think that was after I rolled back and still had the 6.0.6 guest extensions pack installed. So, rather, I have only a verifiable issue with a Windows 7 VM.
Comment by Nick Stefanov (mozo) - Thursday, 18 April 2019, 10:37 GMT
Same problem here. Windows 7 don't boot with a BSOD. My Arch installation is up to date.
Comment by Juan Simón (j1simon) - Thursday, 18 April 2019, 13:52 GMT
I've tested the official release: https://www.virtualbox.org/wiki/Linux_Downloads (https://download.virtualbox.org/virtualbox/6.0.6/VirtualBox-6.0.6-130049-Linux_amd64.run) and it works well.
Comment by Nick Stefanov (mozo) - Thursday, 18 April 2019, 14:27 GMT
Yes I tried it too and it's working without problems.
Comment by Chih-Hsuan Yen (yan12125) - Thursday, 18 April 2019, 15:56 GMT
OK I found the cause - iasl from acpica 20190329-1 miscompiles ACPI tables of VirtualBox. Building with older acpica fixes the issue:

multilib-build -- -I /var/cache/pacman/pkg/acpica-20190215-1-x86_64.pkg.tar.xz
Comment by yanlin (godspeed) - Friday, 19 April 2019, 02:20 GMT
Same problem. Windows 7 don't boot with a BSOD.
Ubuntu 16.04.3 and Windows XP boot fine
Comment by Chih-Hsuan Yen (yan12125) - Friday, 19 April 2019, 03:48 GMT
VirtualBox building with acpica 20190405 is also broken. That might be an upstream bug in acpica.
Comment by Bruno Pagani (ArchangeGabriel) - Friday, 19 April 2019, 07:11 GMT
Then you should report upstream. ;)
Comment by Chih-Hsuan Yen (yan12125) - Friday, 19 April 2019, 09:19 GMT
Here you go https://github.com/acpica/acpica/issues/462. Took some time understanding ACPI tables :)
Comment by Chih-Hsuan Yen (yan12125) - Sunday, 21 April 2019, 02:25 GMT
Bruno Pagani, Laurent Carlier: Looks like upstream developers need some time to fix the acpica issue. I hope community/virtualbox does not stay in a broken state for too long. How about reverting community/acpica to a working version so that Christian Hesse can rebuild virtualbox easily? (e.g., with simply `multilib-build`, not bothering with `-I` and old acpica packages)
Comment by Christian Hesse (eworm) - Sunday, 21 April 2019, 17:34 GMT
I do not care the build number difference. We build from official source tarball, if that is wrong go and blame Oracle.

I've just push new virtualbox packages built with old acpica. Let's keep this open to track upstream acpica issue.
Comment by Juan Simón (j1simon) - Monday, 22 April 2019, 08:12 GMT
One thing is obvious: if the official package (downloaded from the Virtualbox website) works and the package created by Arch fails... Where is the problem?
Comment by Christian Hesse (eworm) - Monday, 22 April 2019, 19:10 GMT
Are you serious? You should read above...
Comment by Juan Simón (j1simon) - Tuesday, 23 April 2019, 09:56 GMT
The new virtualbox packages in Arch repositories works well.
Comment by Vladislav Glinsky (CL0NE) - Thursday, 25 April 2019, 19:53 GMT
Can confirm that 6.0.6-2 works well
Comment by Bruno Pagani (ArchangeGabriel) - Friday, 10 May 2019, 14:00 GMT
There is a new acpica in the repo, if it works OK for VirtualBox we can close this bug.
Comment by Chih-Hsuan Yen (yan12125) - Friday, 10 May 2019, 16:26 GMT
Looks like virtualbox works fine if built with the latest acpica. I've asked upstream devs if the issue is completely fixed or not: https://github.com/acpica/acpica/issues/462#issuecomment-491347262.
Comment by Chih-Hsuan Yen (yan12125) - Saturday, 11 May 2019, 00:43 GMT
Closing as upstream devs confirms the issue is completely fixed :)

Loading...