Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62364 - [w3m] w3mimgdisplay should be in /usr/bin by default

Attached to Project: Arch Linux
Opened by Ellis Kenyo (elken) - Tuesday, 16 April 2019, 11:01 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 22 May 2019, 09:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

/usr/lib/w3mimgdisplay should be in /usr/bin by default as it is used by packages like ranger.

`pacman -Ql w3m`:

w3m /usr/
w3m /usr/bin/
w3m /usr/bin/w3m
w3m /usr/bin/w3mman
...
w3m /usr/lib/w3m/inflate
w3m /usr/lib/w3m/w3mimgdisplay
w3m /usr/lib/w3m/xface2xpm
...
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 22 May 2019, 09:55 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Wednesday, 22 May 2019, 09:55 GMT
Ranger has some nice hardcoded defaults:
W3MIMGDISPLAY_PATHS = [
'/usr/lib/w3m/w3mimgdisplay',
'/usr/libexec/w3m/w3mimgdisplay',
'/usr/lib64/w3m/w3mimgdisplay',
'/usr/libexec64/w3m/w3mimgdisplay',
'/usr/local/libexec/w3m/w3mimgdisplay',
]

Loading...