Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62352 - [linux] Touchpad tap-to-click stopped working in Plasma after update to linux 5.0

Attached to Project: Arch Linux
Opened by Nicola Mori (snack) - Monday, 15 April 2019, 10:23 GMT
Last edited by Antonio Rojas (arojas) - Monday, 20 May 2019, 11:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The touchpad of my Dell XPS 15 9570 worked flawlessly with Plasma desktop up to kernel 4.20. After upgrading to kernel 5.0 the tap-to-click and the scrolling with two fingers functions stopped working. The settings in KDE KCM are ignored. I tried to boot with LTS kernel 4.19 and with this version the touchpad works as expected.

Additional info:
* package version(s)
linux-ck-skylake 5.0.5-1
linux-lts 4.19.34-1

* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
1) install kernel 5.0 and Plasma dektop, boot and try to click with a tap on the touchpad: it should not work.
2) boot with LTS kernel 4.19 and try agai: it should work
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 20 May 2019, 11:41 GMT
Reason for closing:  Upstream
Additional comments about closing:  unsupported kernel
Comment by Nicola Mori (snack) - Thursday, 18 April 2019, 18:57 GMT
I played a bit with KCM settings and suddenly the touchpad began to work again as expected. I don't remember what I did exactly, but I think it's noteworthy that today I updated the kernel to 5.0.8. Maybe the issue has been fixed in upstream kernel.
Comment by Nicola Mori (snack) - Monday, 22 April 2019, 16:05 GMT
I spoke too quick. After a reboot the touchpad does not work again. I filed a bug report to KDE: https://bugs.kde.org/show_bug.cgi?id=406778

Loading...