Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62296 - finfo::finfo(): Failed to load magic database at ..

Attached to Project: Arch Linux
Opened by Francois (francoism90) - Wednesday, 10 April 2019, 12:43 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 10 April 2019, 13:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
<?php
echo (new finfo(FILEINFO_MIME, "/srv/http/project/public/index.php"));

// PHP Fatal error: Uncaught Exception: finfo::finfo(): Failed to load magic database at '/srv/http/project/public/index.php'. in /srv/http/project/tempCodeRunnerFile.php:2


Additional info:
* php 7.3.4-2
* provided php.ini

Steps to reproduce:
It's really weird, as this never happened before. I'll try to see if downgrading helps, as it does it seem to be a compile/config(?) error.
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 10 April 2019, 13:37 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Wednesday, 10 April 2019, 13:37 GMT
This is not a bug but a problem with your code.

finfo __construct takes a magic database as 2nd parameter, your 2nd parameter clearly is not a magic database.

Loading...