Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62295 - [evolution] Calendar sync freeze on Evolution 3.32.1-1

Attached to Project: Arch Linux
Opened by Marc-Olivier Barre (mobarre) - Wednesday, 10 April 2019, 11:42 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 17 January 2020, 13:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Syncing the calendars fails/never completes since the update to 3.32.1-1. Same goes for tasks.

The message displayed is: Error creating view for the task list "Task" : no such method "start"

Additional info:
* package version(s) 3.32.1-1

Steps to reproduce:
Start evolution with remote task lists or calendars configured. Same issue with both classical Caldav and Exchange.

It started when the following upgrade went through apparently:
[2019-04-09 11:17] [ALPM] upgraded evolution-data-server (3.32.0-2 -> 3.32.1-1)
[2019-04-09 11:17] [ALPM] upgraded evolution (3.32.0-1 -> 3.32.1-1)
[2019-04-09 11:17] [ALPM] upgraded evolution-ews (3.32.0-1 -> 3.32.1-1)
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 17 January 2020, 13:38 GMT
Reason for closing:  Fixed
Comment by Marc-Olivier Barre (mobarre) - Wednesday, 10 April 2019, 11:45 GMT
I just attempted a rollback to previous version of those 3 packages to make sure. The issue went away. Tasks and calendar entry sync and display correctly.
Comment by Ralf Mardorf (Ralf) - Friday, 12 April 2019, 07:33 GMT
This bug seems to be related to https://bugs.archlinux.org/task/62317, since the whole Contacts, Calender etc. thingy seems to be affected.
I wonder that you didn't need to provide 2 versions of icu on an up to date Arch Linux, too, when downgrading evolution.

I didn't report it to the upstream bug tracker, but send a request to the mailing list.

https://mail.gnome.org/archives/evolution-list/2019-April/msg00066.html

I'm not using Calender etc., I just missed contacts when auto-complete for "To:" didn't work.

Followup:

https://mail.gnome.org/archives/evolution-list/2019-April/msg00068.html
Comment by Ralf Mardorf (Ralf) - Saturday, 22 June 2019, 11:15 GMT
Does it make sense to continue upgrading the package from one broken release to the next broken release?

$ grep down /var/log/pacman.log | grep 'evolution (3.32'
[2019-04-12 03:22] [ALPM] downgraded evolution (3.32.1-1 -> 3.32.0-1)
[2019-05-07 08:16] [ALPM] downgraded evolution (3.32.2-1 -> 3.32.0-1)
[2019-06-22 13:02] [ALPM] downgraded evolution (3.32.3-1 -> 3.32.0-1)
Comment by Ralf Mardorf (Ralf) - Monday, 05 August 2019, 10:50 GMT
Bug #62317 is solved, see https://bugs.archlinux.org/task/62317 .

After upgrading and closing the old version of Evolution, try running

pkill -9 evolution

before you open the upgraded Evolution.

Loading...