Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62230 - Curl does not resolve domains under a chrooted user in the ISO anymore.

Attached to Project: Arch Linux
Opened by Martin Rys (C0rn3j) - Thursday, 04 April 2019, 16:44 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 23 November 2019, 16:10 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
I used to install an AUR package by doing sudo -i (or su) to a normal user account and then running makepkg under that user.
This broke at some point, it seems to be a curl issue, as 'drill' can resolve just fine.


Steps to reproduce:
Boot the latest ISO and run the attached install script. Line 90 (sudo -u ${username} curl http://github.com) will throw a resolve error.

Running the same command with sudo as that user will work.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 23 November 2019, 16:10 GMT
Reason for closing:  Fixed
Comment by Dave Reisner (falconindy) - Thursday, 04 April 2019, 17:07 GMT
What does /etc/resolv.conf look like inside and outside the chroot? Is it a symlink? A regular file? What are the contents?
Comment by Martin Rys (C0rn3j) - Thursday, 04 April 2019, 17:09 GMT
I tried changing it to just

nameserver 1.1.1.1

in the chroot when testing(my DHCP gives 8.8.8.8, 1.1.1.1 and some IPv6 ones), and it still bugged out.

EDIT: As to what file it is, whatever the default is as you can see in the repro script - I don't touch resolv.conf
EDIT2: Also something to add even though am sure this is obvious - test on a VM, this script will format data.
Comment by Martin Rys (C0rn3j) - Monday, 18 November 2019, 06:11 GMT
Now it works again.

Fixed the repro script in case it will be needed in the future if this resurfaces...

Loading...