Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62210 - [mplayer] terminates after giflib upgrade

Attached to Project: Arch Linux
Opened by Eivind (mokkurkalve) - Tuesday, 02 April 2019, 02:44 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 02 April 2019, 06:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Sven-Hendrik Haase (Svenstaro)
Levente Polyak (anthraxx)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I don't know if this is really a bugreport on mplayer or giflib but after upgrading gilib to 5.1.9-1 mplayer terminates with:
mplayer: symbol lookup error: mplayer: undefined symbol: GifQuantizeBuffer
Downgrading giflib to 5.1.8-1 fixes the problem.


Additional info:
* package version(s)
mplayer 38125-1
giflib 5.1.9-1

* config and/or log files etc.

* link to upstream bug report, if any

Steps to reproduce:
Upgrade giflib, run mplayer.

This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 02 April 2019, 06:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  mplayer 38125-2
Comment by Allan McRae (Allan) - Tuesday, 02 April 2019, 04:06 GMT
  • Field changed: Severity (Low → Critical)
Setting as critical because I want to watch a movie!
Comment by stream9 (stream9) - Tuesday, 02 April 2019, 04:08 GMT
It seems giflib drop GifQuantizeBuffer() which mplayer depends on unannounce.

They have problem building library on Windows, so just purge Windows unfriendly parts from library.
Breaking ABI unannounce seems highly unusual to me. I suggest reverting library to 5.1.8 until issue is resolved.

Related bug: https://sourceforge.net/p/giflib/bugs/129/
Commit for fix: https://sourceforge.net/p/giflib/code/ci/0678919b74777eb957e3a17c5657f5aa46c0aafa/
Comment by Allan McRae (Allan) - Tuesday, 02 April 2019, 04:13 GMT
Rebuilding mplayer against the new giflib also fixes this issue.
Comment by Antonio Rojas (arojas) - Tuesday, 02 April 2019, 06:48 GMT
> Breaking ABI unannounce seems highly unusual to me. I suggest reverting library to 5.1.8 until issue is resolved.

If the ABI break is actually intended, as it seems, then reverting to 5.1.8 is simply going to cause more breakage for packages that are built against it.

Loading...