Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62204 - [mate-netbook] Segmentation fault in mate-maximus

Attached to Project: Community Packages
Opened by Étienne Deparis (milouse) - Monday, 01 April 2019, 09:32 GMT
Last edited by Balló György (City-busz) - Friday, 12 April 2019, 15:21 GMT
Task Type Bug Report
Category Upstream Bugs
Status Assigned
Assigned To Brad Fanella (cesura)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

Description:

Since the last update of mate-netbook (version 3.22.0), mate-maximus crashes at startup, reporting a segmentation fault error.

Additional info:
* mate-netbook 3.22.0
* fixed upstream by last master commit https://github.com/mate-desktop/mate-netbook/commit/25f0f7141eebcb8605ddeb2c70c9a8726984545e but not released yet

Could it be possible to release a 3.22.0-2 version of the package, including this last commit as a temporary patch?

Steps to reproduce:

Start mate-maximus
This task depends upon

Comment by Étienne Deparis (milouse) - Monday, 01 April 2019, 12:33 GMT
Nothing related to this bug, but @Brad, if you don't mine, could you also change the mate-netbook description? Now that mate is fully compliant with gtk3, the "(GTK2 version)" part of the package description is no more usefull.

Sorry for flooding this ticket, but as it's really really minor, I would not open a new ticket just for that. Thank you for your understanding.
Comment by Valentín Huélamo (ValHue) - Tuesday, 02 April 2019, 16:04 GMT
Hello Etienne,
the version I suppose you wanted to indicate the 1.22.0 (the 3.22 will be gnome or other)

I have solved it with this patch

https://pastebin.com/y9vcggKN

and this PKGBUILD

https://pastebin.com/zxRavUWq

Best regards,
Valentín Huélamo
Comment by Étienne Deparis (milouse) - Wednesday, 03 April 2019, 08:22 GMT
Oh yes sorry, I was speaking about the 1.22.0 version (the current last one). I don't know why I put a three instead. Sorry again.

Loading...