Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62192 - [matrix-synapse] post_install still hints to python2

Attached to Project: Community Packages
Opened by Giovanni Harting (IdleGandalf) - Saturday, 30 March 2019, 09:50 GMT
Last edited by Johannes Löthberg (demize) - Sunday, 31 March 2019, 13:11 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Johannes Löthberg (demize)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

The text printed in post_install still refers to python2, should be pointing to python, will fail otherwise (well, it currently fails even with python3, due to a dependency conflict, but that is not the point here).

$ sudo -u synapse python2 -m synapse.app.homeserver --server-name my.domain.name --config-path /dev/null --generate-config --report-stats=no
/usr/bin/python2: No module named synapse.app

https://git.archlinux.org/svntogit/community.git/tree/trunk/synapse.install?h=packages/matrix-synapse#n12

Additional info:
matrix-synapse 0.99.2-2

This task depends upon

Closed by  Johannes Löthberg (demize)
Sunday, 31 March 2019, 13:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.99.2-3

Loading...