Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62189 - [firefox] Since v64, support of xdg-desktop-portal is enabled

Attached to Project: Arch Linux
Opened by BrLi (brli) - Saturday, 30 March 2019, 02:57 GMT
Last edited by Jan Alexander Steffens (heftig) - Saturday, 30 March 2019, 21:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

As in the source urls provided below, firefox supports some other DE-native things via xdg portal.

Please

1. update firefox.desktop to include the env variable `GTK_USE_PORTAL=1` at `Exec=` lines before calling firefox
2. update optdepends in PKGBUILD to include `xdg-desktop-portal-kde: native KDE file dialog support`

Additional info:
* package version(s) 66.0.2-1
* config and/or log files etc.

PKGBUILD
firefox.desktop

* link to upstream bug report, if any

https://pointieststick.com/2018/12/16/this-week-in-usability-productivity-part-49/
https://phabricator.kde.org/T10189
https://bugs.kde.org/show_bug.cgi?id=402077


Steps to reproduce:

1. Under Plasma/KDE
2. Open Firefox
3. go to google.com
4. Right click on the doodle
5. "Save Image as"
6. a GTK file dialog pops up
However, with the environment variable, a plamsa file dialog would pop up.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Saturday, 30 March 2019, 21:03 GMT
Reason for closing:  Won't fix
Additional comments about closing:  This is not a Firefox feature.
Comment by Antonio Rojas (arojas) - Saturday, 30 March 2019, 09:14 GMT
This may be suitable for distros that use Plasma by default, but Arch users are expected to be able to configure their systems themselves. Also, why add this specifically to firefox and not to all other GTK applications?
Comment by BrLi (brli) - Saturday, 30 March 2019, 10:04 GMT
It might be that only Firefox recognize this variable? Or, not all GTK applications had implemented this portal yet? (for the last question)

Also, this addition to Exec line has no impact on other DE/non-DE, but it does add something for Plasma.

Besides, it is upstreamed in mozilla, thus I think Arch should also ship it as reflection.
Comment by Jake Kreiger (Magali75) - Saturday, 30 March 2019, 10:58 GMT
@arojas I think this is only for firefox. Currently it crashes thunderbird and will do until mid-year update: https://bugzilla.mozilla.org/show_bug.cgi?id=1514605

I also think upstream should decide about enabling this as default. This is still very new feature with bugs. For example uploading files to website with native file dialog doesn't works for me.
Comment by Antonio Rojas (arojas) - Saturday, 30 March 2019, 11:13 GMT
No, this is a gtk thing, not Firefox specific. It works with other gtk applications, even before it did for Firefox

It is also nothing KDE specific, so of course it will impact other DE. This will make gtk file dialogs go through xdg-portal whenever any of its implementations is installed, and possibly break them completely with some combination of installed packages
Comment by BrLi (brli) - Saturday, 30 March 2019, 11:23 GMT
@arojas You missed my point here:

By "only add the variable into Exec= line of firefox.desktop", we can assure this variable has no impact "using firefox on other DE/non-DE"
"Not" that "this variable has no impact on other DE/non-DE".

_Plus_, since the `xdg-desktop-portal` may impact other GTK packages as you mentioned, I propose the `xdg-desktop-portal-kde` should be in optdepends instead of hard depends.
Which would lower the risk of break other GTK applications.

@Magali75, when did you test the upload feature?
The plasma team had fixed the portal at 5.14.5 release as per of kde bug #402077 shows above.
And I've just test it, it works on twitter when attaching images.
Comment by BrLi (brli) - Saturday, 30 March 2019, 11:29 GMT
the more elegant way might be include this variable inside wrapper at https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/firefox#n161

instead of implement it in .desktop
Comment by Jake Kreiger (Magali75) - Saturday, 30 March 2019, 20:41 GMT
@brli couple of days ago. Not on twitter.
Comment by Antonio Rojas (arojas) - Saturday, 30 March 2019, 20:58 GMT
"By "only add the variable into Exec= line of firefox.desktop", we can assure this variable has no impact "using firefox on other DE/non-DE"
"Not" that "this variable has no impact on other DE/non-DE""

I have no idea what the difference bewteen those two sentences is.

Anyway, I'll leave it to the firefox maintainer to (probably) close this

Loading...