Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62083 - [gtk3] After todays update, GTK is crashing the entire GNOME desktop

Attached to Project: Arch Linux
Opened by Britt Yazel (brittyazel) - Wednesday, 20 March 2019, 00:32 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 20 March 2019, 05:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Upon updating GTK today, Mar 19, 2019, GTK is not using the default GNOME theme, has a wrong configuration (it is showing the minimize and maximize buttons for some reason), and is causing the entire GNOME desktop to crash. This happens consistently 1-2 min after logging in, and reverting GTK 3.24 fixes this issue.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 20 March 2019, 05:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  gtk3 1:3.24.7+11+g3a959e984f
Comment by Doofen (Sangeppato) - Wednesday, 20 March 2019, 00:38 GMT
Same here, Gnome is completely broken and unusable with the latest gtk3 update
Comment by loqs (loqs) - Wednesday, 20 March 2019, 01:09 GMT
Can you check if 3a959e984f558d763db03f6bee53cc5bb9470a26 is good and 05bc2f4dc122594aff3325c41421fc0de9153460 is bad please.
Comment by Mortan (Mortan1961) - Wednesday, 20 March 2019, 01:27 GMT
gtk3 3.24.7+19+g91f2ad4a2f-1 breaks GTK and icon themes, breaks logging out, and causes crashes. Worked with 3.24.7-1. Please revert as soon as possible.
Comment by Doug Newgard (Scimmia) - Wednesday, 20 March 2019, 01:30 GMT
Logs?
Comment by Mortan (Mortan1961) - Wednesday, 20 March 2019, 01:47 GMT
I found a forum post indicating that it might not be the gtk3 package: https://bbs.archlinux.org/viewtopic.php?pid=1837923
Comment by Mortan (Mortan1961) - Wednesday, 20 March 2019, 01:50 GMT
Looking at my systemd journal I am getting:
gnome-shell: g_callable_info_get_n_args: assertion 'info != NULL' failed
Comment by loqs (loqs) - Wednesday, 20 March 2019, 01:51 GMT
Does downgrading gtk3 to 3.24.7-1 not resolve the issue for you? What about logs?
Comment by Sam (waxymouthfeel) - Wednesday, 20 March 2019, 01:55 GMT
I can't speak to themes, but after updating today gtk3 crashes after a few minutes. Logs are a bit difficult for me to acquire at the moment, but I can confirm downgrading to 3.24.7-1 stops the crashing.

One thing I did notice is the size of my mouse pointer changing at random between the desktop and apps like firefox. That might point to some HIDPI weirdness.
Comment by Mortan (Mortan1961) - Wednesday, 20 March 2019, 02:01 GMT
I don't have the old cached package, so I can't downgrade right now.
Comment by loqs (loqs) - Wednesday, 20 March 2019, 02:14 GMT Comment by Mortan (Mortan1961) - Wednesday, 20 March 2019, 02:33 GMT
Downgrading from 3.24.7+19+g91f2ad4a2f-1 to 3.24.7-1 resolves the issues.
Comment by Mortan (Mortan1961) - Wednesday, 20 March 2019, 02:38 GMT
However, I still get that failed assertion so it is apparently unrelated.

Edit: Fixed the email. I did not know that was an issue because it is not listed anywhere and I do not want any emails. Sorry for the notifications. Thought that Edit was for fixing spelling issues and that updates should be more appropriately placed in new comments.
Comment by Doug Newgard (Scimmia) - Wednesday, 20 March 2019, 02:43 GMT
Mortan, fix your account or it will be removed. A valid email is REQUIRED.

Also, start using edit and stop spamming notifications.
Comment by Nick Tindall (nicktee) - Wednesday, 20 March 2019, 05:15 GMT
I had the same issue and downgrading gtk3 to 3.24.7-1 did resolve it

Loading...