Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62050 - [mplayer] doesn't build (error in libsmbclient)

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Monday, 18 March 2019, 06:51 GMT
Last edited by Levente Polyak (anthraxx) - Thursday, 28 March 2019, 20:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

In file included from stream/stream_smb.c:21:
/usr/include/samba-4.0/libsmbclient.h:158:18: error: field 'btime_ts' has incomplete type
struct timespec btime_ts;
^~~~~~~~
/usr/include/samba-4.0/libsmbclient.h:162:18: error: field 'mtime_ts' has incomplete type
struct timespec mtime_ts;
^~~~~~~~
/usr/include/samba-4.0/libsmbclient.h:166:18: error: field 'atime_ts' has incomplete type
struct timespec atime_ts;
^~~~~~~~
/usr/include/samba-4.0/libsmbclient.h:170:18: error: field 'ctime_ts' has incomplete type
struct timespec ctime_ts;
^~~~~~~~
make: *** [Makefile:726: stream/stream_smb.o] Error 1
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Build failed, check /var/lib/archbuild/staging-x86_64/abaumann/build

Additional info:

package version(s): 38101-2

link to upstream bug report, if any

https://forums.gentoo.org/viewtopic-t-1086966-start-0.html
https://bugs.gentoo.org/666548

This seems to be a patch in Gentoo for the same problem.

Steps to reproduce:

asp export mplayer
cd mplayer
staging-x86_64-build
This task depends upon

Closed by  Levente Polyak (anthraxx)
Thursday, 28 March 2019, 20:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  38125-1
Comment by Andreas Baumann (andreas_baumann) - Thursday, 21 March 2019, 07:07 GMT
/usr/include/samba-4.0/libsmbclient.h:158:18: error: field 'btime_ts' has incomplete type
struct timespec btime_ts;

actually, the root error is in samba, not including all required header files (time.h)
for it's public header files.

So, as hotfix for mplayer:

#include <time.h>

before

#include <samba-4.0/libsmbclient.h>

in stream/stream_smb.c

does the trick.

Loading...