Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62046 - gsettings-desktop-schemas 3.32.0-2 has dependencies that should be marked optional

Attached to Project: Arch Linux
Opened by Robin Broda (coderobe) - Sunday, 17 March 2019, 16:28 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 10 December 2019, 19:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 9
Private No

Details

Description:
gsettings-desktop-schemas 3.32.0-2 has added new dependencies on default fonts `cantarell-fonts` & `adobe-source-code-pro-fonts`

They are not required for the schemas and as such should be marked optional dependencies instead.

The package functions fine without these font packages, they are only required when other software reads the font settings from the schema.
This task depends upon

Comment by battuta (battuta) - Sunday, 01 December 2019, 01:22 GMT
I also would like the fonts dependencies to be amended. I don't really mind `cantarell-fonts` being there, since it's already a dependency of `gtk3` and several GNOME apps, but I'd rather not have Adobe Source Code Pro installed if it's not needed.

Loading...