Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62025 - [nautilus] 3.32 requires gsettings schemas from tracker-miners

Attached to Project: Arch Linux
Opened by Joonas Henriksson (ooo) - Saturday, 16 March 2019, 00:44 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 10 April 2019, 13:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
After update to nautilus-3.32.0-1, nautilus fails to start with the following error:

(org.gnome.Nautilus:18394): GLib-GIO-ERROR **: 02:37:48.715: Settings schema 'org.freedesktop.Tracker.Miner.Files' is not installed
Trace/breakpoint trap (core dumped)


Installing tracker-miners-2.2.1-1 resolves the issue, allowing nautilus to start again.
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 10 April 2019, 13:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 3.32.0-2.
Comment by Mike Cardillo (mcardillo55) - Saturday, 16 March 2019, 01:07 GMT
Also seeing this bug. Installing tracker-miners resolves for me as well.
Comment by Ruslan Sharafeev (iFaizi) - Saturday, 16 March 2019, 01:16 GMT
I confirm that the installation of tracker-miners package starts the Nautilus...
Comment by Kev (Kev) - Saturday, 16 March 2019, 16:08 GMT
I can confirm this issue.

Message in dmesg is:
traps: nautilus[4425] trap int3 ip:7ff683c43186 sp:7ffeb4e75100 error:0 in libglib-2.0.so.0.6000.0 [7ff683bf9000+85000]
Comment by Gerson J Ferreira (gersonjferreira) - Monday, 18 March 2019, 14:23 GMT
Is there any other workaround that does not require installing tracker-miners?

I personally don't like gnome tracker, since the indexing is slow on large HDDs, and I'm fine with the regular search for file names. So, I would prefer not to install tracker-miners, and the new update requires me to install it as a dependency.

I'm sure there are others who prefer not to install tracker-miners. Or even tracker at all!

Loading...