Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62022 - [gtk2] Build breaks with automake 1.16.x

Attached to Project: Arch Linux
Opened by helle vaanzinn (glitsj16) - Friday, 15 March 2019, 10:42 GMT
Last edited by Jan de Groot (JGC) - Friday, 23 August 2019, 21:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Building gtk2 2.24.32-1 breaks due to unsupported automake version

Additional info:
* package version(s)

$ pacman -Q automake
automake 1.16.1-1

$ makepkg
==> Making package: gtk2 2.24.32-1 (2019-03-15T11:13:06 CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning gtk git repo...
Cloning into bare repository '/home/glitsj16/buildzone/gtk2/gtk'...
remote: Enumerating objects: 500956, done.
remote: Counting objects: 100% (500956/500956), done.
remote: Compressing objects: 100% (87428/87428), done.
remote: Total 500956 (delta 414112), reused 499250 (delta 412880)
Receiving objects: 100% (500956/500956), 334.06 MiB | 1.99 MiB/s, done.
Resolving deltas: 100% (414112/414112), done.
-> Found gtkrc
-> Found gtk-query-immodules-2.0.hook
-> Found xid-collision-debug.patch
==> Validating source files with sha256sums...
gtk ... Skipped
gtkrc ... Passed
gtk-query-immodules-2.0.hook ... Passed
xid-collision-debug.patch ... Passed
==> Extracting sources...
-> Creating working copy of gtk git repo...
Cloning into 'gtk'...
done.
Checking out files: 100% (4743/4743), done.
Checking out files: 100% (6459/6459), done.
Switched to a new branch 'makepkg'
==> Starting prepare()...
patching file gdk/x11/gdkxid.c

You must have automake 1.7.x, 1,10.x, 1.11.x, 1.12.x, 1.13.x, 1.14.x
or 1.15.x installed to compile Gtk+.
Install the appropriate package for your distribution,
or get the source tarball at http://ftp.gnu.org/gnu/automake/
==> ERROR: A failure occurred in prepare().
Aborting...

Using this patch fixes building with current automake:
--- a/autogen.sh
+++ b/autogen.sh
@@ -48,7 +48,10 @@
DIE=1
}

-if automake-1.15 --version < /dev/null > /dev/null 2>&1 ; then
+if automake-1.16 --version < /dev/null > /dev/null 2>&1 ; then
+ AUTOMAKE=automake-1.16
+ ACLOCAL=aclocal-1.16
+else if automake-1.15 --version < /dev/null > /dev/null 2>&1 ; then
AUTOMAKE=automake-1.15
ACLOCAL=aclocal-1.15
else if automake-1.14 --version < /dev/null > /dev/null 2>&1 ; then
@@ -71,11 +74,12 @@
ACLOCAL=aclocal-1.7
else
echo
- echo "You must have automake 1.7.x, 1,10.x, 1.11.x, 1.12.x, 1.13.x, 1.14.x"
- echo "or 1.15.x installed to compile $PROJECT."
+ echo "You must have automake 1.7.x, 1,10.x, 1.11.x, 1.12.x, 1.13.x, 1.14.x, 1.15.x"
+ echo "or 1.16.x installed to compile $PROJECT."
echo "Install the appropriate package for your distribution,"
echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/";
DIE=1
+fi
fi
fi
fi
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 23 August 2019, 21:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in svn

Loading...