Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#62002 - [libheif] needs rebuild after libjpeg update?

Attached to Project: Arch Linux
Opened by Adam Fontenot (amfontenot) - Thursday, 14 March 2019, 03:32 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 14 March 2019, 03:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Any heif-convert command dies immediately with

relocation error: heif-convert: symbol jpeg_write_icc_profile version LIBJPEG_8.0 not defined in file libjpeg.so.8 with link time reference

I think this is due to a mismatch with the installed libjpeg. Rebuilding libheif from the PKGBUILD solves the problem for me. Note that my jpeg library is mozjpeg. I don't think that's the problem but if so let me know and I'll report it upstream.

Additional info:
* libheif 1.4.0-1
* mozjpeg 3.3.1-1

Steps to reproduce:

Run heif-convert (e.g. heif-convert -h).
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 14 March 2019, 03:44 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Unsupported libjpeg

Loading...