Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61999 - [mbedtls] The packaged version is not the Apache licensed one

Attached to Project: Community Packages
Opened by Mike Sharov (msharov) - Wednesday, 13 March 2019, 22:51 GMT
Last edited by Levente Polyak (anthraxx) - Tuesday, 10 March 2020, 20:34 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
mbedtls is distributed in both Apache and GPL2 versions in separate archives. This Arch package claims to package the Apache version, but actually packages the GPL2 version. You can tell the difference by examining the included header files, which, as packaged, indicate that it is GPL2. This makes it illegal for any non-GPL packages requiring it, such as shadowsocks, to link to it.
This task depends upon

Closed by  Levente Polyak (anthraxx)
Tuesday, 10 March 2020, 20:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.16.5-1

Loading...