Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61982 - [gnome-control-center] segfault when trying to set time

Attached to Project: Arch Linux
Opened by Leopold Bloom (leopoldbloom) - Tuesday, 12 March 2019, 01:59 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 14 March 2019, 17:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
Gnome Settings segfaults when trying to set the date/time and spits out the stack trace attached. More info on the journal entries preceding it can be provided if necessary.

Strangely enough, if I forcefully reset all GNOME-related settings with dconf reset -f /org/gnome/, it works again...until I open the Date/Time section. It then segfaults until I do the dconf force-reset again.

Additional info:
* package version: 3.30.3-1
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 14 March 2019, 17:34 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#61974 
Comment by François Guerraz (kubrick) - Tuesday, 12 March 2019, 08:06 GMT
Same here, can't launch the control center since I updated my timezone.
Comment by François Guerraz (kubrick) - Tuesday, 12 March 2019, 17:39 GMT
downgrading to glib2-2.58.3 (vs the newer 2.60.0) fixes the issue.
Comment by James Swineson (Jamesits) - Wednesday, 13 March 2019, 02:51 GMT
Can reproduce here, except I got stuck displaying the "About" page rather than date/time settings.

Package versions:
gnome-control-center 3.30.3-1
glib2 2.60.0-1

Downgrading to glib2 2.58.3 also fixed the problem for me.
Comment by François Guerraz (kubrick) - Wednesday, 13 March 2019, 07:37 GMT
you can also reset which panel was visited last and avoid going to the "Details" panel until this is fixed.

gsettings reset org.gnome.ControlCenter last-panel

Tracked upstream: https://gitlab.gnome.org/GNOME/gnome-control-center/issues/411
Comment by Doofen (Sangeppato) - Wednesday, 13 March 2019, 22:12 GMT Comment by loqs (loqs) - Wednesday, 13 March 2019, 23:27 GMT Comment by Doofen (Sangeppato) - Thursday, 14 March 2019, 15:33 GMT
Isn't this going to be updated?
Comment by François Guerraz (kubrick) - Thursday, 14 March 2019, 16:45 GMT
You can use this PKGBUILD if you want, or if you trust me (which you shouldn't) you can download this package: https://send.firefox.com/download/9170e00f39/#_p57UznoqsMJswzCD5e_-g
   PKGBUILD (1.9 KiB)
Comment by Doofen (Sangeppato) - Thursday, 14 March 2019, 17:15 GMT
Thanks, but shouldn't this package be officially updated anyway? I mean, to me this is a quite annoying bug and the fix is there..

Loading...