Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61964 - Linux 5.0 XPS 15 9570 Built in screen blinks but doesn't show anything.

Attached to Project: Arch Linux
Opened by Chris Roth (CaeZaR) - Sunday, 10 March 2019, 00:15 GMT
Task Type Bug Report
Category Packages: Core
Status Unconfirmed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 20
Private No

Details

Description:

I have a Dell XPS 15 9570 that I just updated to linux kernel 5 and when I reboot, the built in screen just blinks and doesn't respond to switching to the terminal with Alt-F2. I can get it out of this by attaching a monitor to the HDMI port and then I get a screen on that monitor (and the built it stops blinking, but still doesn't show anything). I'm using the nvidia driver.

I have the following in my mkinitcpio.conf:

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

and this in grub:

GRUB_CMDLINE_LINUX_DEFAULT="nvidia-drm.modeset=1 acpi_rev_override=1 acpi_osi=Linux mem_sleep_default=deep"

I've attached the last journal from the boot.

If anyone can help me figure this out, it would be greatly appreciated. For now, downgrading back to the previous kernel fixes the issue.
This task depends upon

Comment by Jarasłaŭ (ugzuzg) - Sunday, 10 March 2019, 11:56 GMT
Having the same issue.

MODULES=(intel_agp i915)

Boot options:
"Boot with defaults" "rw root=UUID=73d558a5-eb46-46db-b571-68ee2f58731b mem_sleep_default=deep"
Comment by Josh Savage (joshysav) - Monday, 11 March 2019, 10:03 GMT
I am having the same issue too.
Comment by Nicklas Warming Jacobsen (nwj) - Monday, 11 March 2019, 14:41 GMT
Same problem here, but I'm using the Intel card (I've blacklisted both nouveau and nvidia). I'll post a journal dump when I get home.
Comment by Chris Roth (CaeZaR) - Monday, 11 March 2019, 16:04 GMT
If any of you have seen a related bug posted on another bug tracker, please post a link. I briefly looked before I opened this thread, but I haven't actively checked for the last couple of days.

Also, to anyone who starts work on this bug, I'm willing to run test patches on my machine to help close off the issue.
Comment by Nicklas Warming Jacobsen (nwj) - Monday, 11 March 2019, 16:15 GMT
The only thing I've found while I've googled around is this "fix" https://invent.kde.org/snippets/44
Comment by GuoKaiYu (kayu_guo) - Tuesday, 12 March 2019, 13:14 GMT
I am having the same issue too.
Comment by Raffael Willems (bigfreak) - Tuesday, 12 March 2019, 17:33 GMT
i am having the same issue too. :-(
Comment by Raffael Willems (bigfreak) - Wednesday, 13 March 2019, 13:25 GMT
the linked fix https://invent.kde.org/snippets/44 works. But 1 of 3 Monitors connected over TB16 Dock have Black Screen and wont come up
Comment by Nicklas Warming Jacobsen (nwj) - Wednesday, 13 March 2019, 13:36 GMT
Raffael: Are you sure it's the same problem as this one, and does it work with the LTS kernel?
Comment by Yang,Binyuan (John b y yang) - Wednesday, 13 March 2019, 14:09 GMT
I am having the same issue too.same machine
Comment by Raffael Willems (bigfreak) - Wednesday, 13 March 2019, 19:11 GMT
@Nicklas: if im booting with Arch Kernel 5.0 nothing happens and the XPS screen blinks (black screen Backlight on, off,on,...) I have changed intel_dp.c in kernel source before compiling linux-ck from aur.
The internal Display works great. don't tested with LTS-Kernel...
Comment by Federico Dolce (docler) - Thursday, 14 March 2019, 21:14 GMT
Having the same issue too, even after the 5.0.1 update, external monitor works though.
Everything works fine with linux-lts kernel
Comment by Emanuele Panigati (ilpanich) - Friday, 15 March 2019, 08:07 GMT
Same issue for me, black screen flashing and system does not boot.
Tested both with kernel 5.0 and 5.0.1, tonight I will give a chance to custom kernl built patching with https://invent.kde.org/snippets/44.
LTS kernel (4.19) and kernel 4.20.13 work smooth.
Comment by Joseph Lawson (joekiller) - Friday, 15 March 2019, 20:36 GMT
I built with the patch 5.0.2 and it fixed my black screen flashing problem that existed since 5.0.0 on a Dell Precision 5530 model number 0x087D BIOS was flashed to 1.8.1 (27 Feb 2019).
Comment by J. Crescoli (joecrescoll) - Saturday, 16 March 2019, 00:38 GMT
I had the same issue since Linux 5.0.0 was released on my XPS 15 9570, but building the kernel (5.0.2) with mentioned patch (https://invent.kde.org/snippets/44) fixed the problem.
Comment by Chris Roth (CaeZaR) - Saturday, 16 March 2019, 01:11 GMT
Does that patch fix the problem for both nvidia and nouveau? Can you add which video card driver you are using with the patch to make 5.0.2 work? Thanks
Comment by Joseph Lawson (joekiller) - Saturday, 16 March 2019, 01:22 GMT
Fwiw I experienced this problem with and without the Nvidia driver. Because only eDP1 was affected and my DP1-2 worked while my laptop screen flickered on and off.

I boot to cli and then startx so this isn't an X thing. When I had the Nvidia driver u uninstalled DP1-2 worked to login bit startx failed obviously. Once I reinstalled Nvidia drivers DP1-2 worked again in X while eDP1 still flickered.

My understanding is that this is like an dp1.x detection issue
Comment by loqs (loqs) - Saturday, 16 March 2019, 01:51 GMT Comment by J. Crescoli (joecrescoll) - Saturday, 16 March 2019, 02:28 GMT
I think joekiller is right about this bug not being related to the nvidia and nouveau drivers :
I blacklisted both modules (nvidia and nouveau) in order to fix another problem I had when using bumblebee with this computer (for more info about this other issue, see <https://bbs.archlinux.org/viewtopic.php?id=238389&p=5#p1826641>), so these drivers should not be the cause of the problem.
Comment by Emanuele Panigati (ilpanich) - Saturday, 16 March 2019, 14:34 GMT
It is not a nvidia or nouveua issue, it is a kernel issue.
In 5.0 they have changed something related to eDP detection which causes the issue.

See also: https://bugzilla.kernel.org/show_bug.cgi?id=202915
Comment by loqs (loqs) - Saturday, 16 March 2019, 15:53 GMT Comment by Stefan Schwarz (foosinn) - Friday, 22 March 2019, 07:58 GMT
I also have the same issue on XPS 15 9570
Comment by Roger Roger (RogerRoger) - Monday, 25 March 2019, 16:52 GMT
Same bug with 5.0.4 are there any proposed fixes or know workarounds yet?
Comment by Emanuele Panigati (ilpanich) - Monday, 25 March 2019, 20:29 GMT
You can patch and rebuild the kernel using one of the following patches:
- https://invent.kde.org/snippets/44
- https://bugs.freedesktop.org/attachment.cgi?id=143729
Comment by Nicola Mori (snack) - Friday, 05 April 2019, 08:40 GMT
Any news about an eventual merge of the patch upstream?
Comment by loqs (loqs) - Wednesday, 10 April 2019, 14:36 GMT Comment by Emanuele Panigati (ilpanich) - Monday, 15 April 2019, 21:17 GMT
From gregkh:

"This is a note to let you know that I've just added the patch titled

drm/i915/dp: revert back to max link rate and lane count on eDP

to the 5.0-stable tree which can be found at:
http://www.kernel.org/git/?p=linux/kernel/git/stable/stable-queue.git;a=summary

The filename of the patch is:
drm-i915-dp-revert-back-to-max-link-rate-and-lane-count-on-edp.patch
and it can be found in the queue-5.0 subdirectory.

If you, or anyone else, feels it should not be added to the stable tree,
please let <stable@vger.kernel.org> know about it."

If everything goes well, it should be included in next stable release.
Comment by Joseph Lawson (joekiller) - Thursday, 18 April 2019, 11:14 GMT
Looks like the patch made 5.0.8.

Loading...