Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61963 - [js60] hg/mercurial is in makedepends but js60 fails to build with staging-x86_64-build

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Saturday, 09 March 2019, 13:55 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 09 March 2019, 14:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

==> Making package: js60 60.5.2-1 (Sat Mar 9 14:52:00 2019)
==> Retrieving sources...
-> Cloning mozilla-unified hg repo...
/usr/share/makepkg/source/hg.sh: line 45: hg: command not found
==> ERROR: Failure while downloading mozilla-unified hg repo
Aborting...
==> ERROR: Could not download sources.

This is IMHO more a problem in makepkg, as 'hg' is used in

source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}esr_RELEASE"

so 'mercurial' should be installed as part of 'base-devel'
like 'git'
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 09 March 2019, 14:42 GMT
Reason for closing:  Not a bug

Loading...