Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61877 - [js52] 52.9.0-2 Makedepend missing - mercurial

Attached to Project: Arch Linux
Opened by Leonid Bloch (blochl) - Wednesday, 27 February 2019, 10:21 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 27 February 2019, 15:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Upon "makepkg -c --verifysource":

```
...
-> Cloning mozilla-unified hg repo...
/usr/share/makepkg/source/hg.sh: line 45: hg: command not found
==> ERROR: Failure while downloading mozilla-unified hg repo
Aborting...
```

Installing mercurial fixes that.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 27 February 2019, 15:35 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Wednesday, 27 February 2019, 11:23 GMT
mercurial is in makedepends.

From the manpage for --verifysource:
Dependencies specified in the PKGBUILD will not be handled unless --syncdeps is used

Comment by Leonid Bloch (blochl) - Wednesday, 27 February 2019, 15:25 GMT
Indeed. Sorry. Requested closure.

Loading...